Changeset 14733 for trunk/CMakeLists.txt


Ignore:
Timestamp:
Apr 23, 2016, 4:13:25 PM (6 years ago)
Author:
mikedld
Message:

#5921: Use libsystemd instead of libsystemd-daemon (original patches by Sandro Tosi and Mike Gilbert)

In systemd v209, released over two years ago, the various libsystemd-*
libraries (libsystemd-journal.so, libsystemd-login.so, libsystem-daemon.so,
libsystemd-id128.so) were merged into a single libsystemd.so library to
reduce code duplication and avoid cyclic dependencies.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/CMakeLists.txt

    r14730 r14733  
    399399    tr_get_required_flag(WITH_SYSTEMD SYSTEMD_IS_REQUIRED)
    400400
    401     pkg_check_modules(SYSTEMD_DAEMON ${SYSTEMD_IS_REQUIRED} libsystemd-daemon)
    402 
    403     tr_fixup_auto_option(WITH_SYSTEMD SYSTEMD_DAEMON_FOUND SYSTEMD_IS_REQUIRED)
     401    pkg_check_modules(SYSTEMD ${SYSTEMD_IS_REQUIRED} libsystemd)
     402
     403    tr_fixup_auto_option(WITH_SYSTEMD SYSTEMD_FOUND SYSTEMD_IS_REQUIRED)
    404404endif()
    405405
Note: See TracChangeset for help on using the changeset viewer.