Changeset 14735


Ignore:
Timestamp:
Apr 24, 2016, 7:41:06 AM (11 months ago)
Author:
mikedld
Message:

Bump minimum Qt version to 4.8

Earlier versions may continue to work, but we don't guarantee they will.

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/CMakeLists.txt

    r14733 r14735  
    265265        set(QT4_REQUIRED_MODULES QtCore QtGui QtNetwork)
    266266        set(QT4_OPTIONAL_MODULES QtDBus QAxContainer QAxServer)
    267         find_package(Qt4 4.6.2 QUIET COMPONENTS ${QT4_REQUIRED_MODULES} OPTIONAL_COMPONENTS ${QT4_OPTIONAL_MODULES})
     267        find_package(Qt4 4.8.0 QUIET COMPONENTS ${QT4_REQUIRED_MODULES} OPTIONAL_COMPONENTS ${QT4_OPTIONAL_MODULES})
    268268        foreach(M ${QT4_REQUIRED_MODULES})
    269269            string(TOUPPER "${M}" M_UPPER)
  • trunk/qt/README.txt

    r14428 r14735  
    3737BUILDING ON UNIX
    3838
    39    1. Prerequisites: Qt >= 4.6 and its development packages
     39   1. Prerequisites: Qt >= 4.8 and its development packages
    4040   2. Build Transmission as normal
    4141   3. In the qt/ directory, type "qmake qtr.pro" (or "qmake-qt4 qtr.pro", or "qmake-qt5 qtr.pro")
Note: See TracChangeset for help on using the changeset viewer.