Changeset 5100 for trunk/configure.ac


Ignore:
Timestamp:
Feb 24, 2008, 3:42:31 PM (13 years ago)
Author:
charles
Message:

(gtk) added optional libnotify support to gtk client. (wereHamster, charles)

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/configure.ac

    r5051 r5100  
    1414GTK_MINIMUM=2.6.0
    1515WX_MINIMUM=2.6.0
     16LIBNOTIFY_MINIMUM=0.4.4
    1617AC_SUBST(GLIB_MINIMUM)
    1718AC_SUBST(GTK_MINIMUM)
    1819AC_SUBST(WX_MINIMUM)
     20AC_SUBST(LIBNOTIFY_MINIMUM)
    1921
    2022AC_PROG_CC
     
    9395AC_SUBST(GTK_CFLAGS)
    9496
     97PKG_CHECK_MODULES([LIBNOTIFY],
     98                  [libnotify >= $LIBNOTIFY_MINIMUM],
     99                  [use_libnotify=yes],
     100                  [use_libnotify=no])
     101AC_SUBST(LIBNOTIFY_LIBS)
     102AC_SUBST(LIBNOTIFY_CFLAGS)
     103if test "x$use_libnotify" = "xyes"; then
     104    AC_DEFINE([HAVE_LIBNOTIFY], 1)
     105fi
     106
    95107IT_PROG_INTLTOOL([0.23],[no-xml])
    96108GETTEXT_PACKAGE=transmission
     
    265277        Build BeOS client:          ${build_beos}
    266278        Build GTK+ client:          ${build_gtk}
     279          ... libnotify support:    ${use_libnotify}
    267280        Build OS X client:          ${build_darwin}
    268281        Build wxWidgets client:     ${build_wx}
Note: See TracChangeset for help on using the changeset viewer.