Changeset 5680


Ignore:
Timestamp:
Apr 24, 2008, 12:02:15 PM (14 years ago)
Author:
charles
Message:

sync the spec file up with the curl requirements

Location:
trunk
Files:
2 edited

Legend:

Unmodified
Added
Removed
  • trunk/configure.ac

    r5673 r5680  
    1111AC_PROG_LIBTOOL
    1212
     13OPENSSL_MINIMUM=0.9.4
    1314CURL_MINIMUM=7.16.0
    1415GIO_MINIMUM=2.15.5
     
    4344AC_SEARCH_LIBS([socket], [socket net])
    4445AC_SEARCH_LIBS([gethostbyname], [nsl bind])
    45 PKG_CHECK_MODULES(OPENSSL, [openssl >= 0.9.4])
    46 PKG_CHECK_MODULES(LIBCURL, [libcurl >= 0.9.4])
     46PKG_CHECK_MODULES(OPENSSL, [openssl >= $OPENSSL_MINIMUM])
     47PKG_CHECK_MODULES(LIBCURL, [libcurl >= $CURL_MINIMUM])
    4748
    4849AC_SYS_LARGEFILE
  • trunk/transmission.spec.in

    r5605 r5680  
    1313
    1414BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
    15 BuildRequires: glib2-devel >= @GLIB_REQUIRED@
    16 BuildRequires: gtk2-devel >= @GTK_REQUIRED@
    17 BuildRequires: libnotify-devel >= @LIBNOTIFY_REQUIRED@
    18 BuildRequires: dbus-glib-devel >= @DBUS_GLIB_REQUIRED@
     15BuildRequires: curl-devel >= @CURL_MINIMUM@
     16BuildRequires: openssl-devel >= @OPENSSL_MINIMUM@
     17BuildRequires: glib2-devel >= @GLIB_MINIMUM@
     18BuildRequires: gtk2-devel >= @GTK_MINIMUM@
     19BuildRequires: libnotify-devel >= @LIBNOTIFY_MINIMUM@
     20BuildRequires: dbus-glib-devel >= @DBUS_GLIB_MINIMUM@
    1921
    20 Requires: glib2 >= @GLIB_REQUIRED@
    21 Requires: gtk2 >= @GTK_REQUIRED@
    22 Requires: libnotify >= @LIBNOTIFY_REQUIRED@
    23 Requires: dbus-glib >= @DBUS_GLIB_REQUIRED@
     22Requires: curl >= @CURL_MINIMUM@
     23Requires: openssl >= @OPENSSL_MINIMUM@
     24Requires: glib2 >= @GLIB_MINIMUM@
     25Requires: gtk2 >= @GTK_MINIMUM@
     26Requires: libnotify >= @LIBNOTIFY_MINIMUM@
     27Requires: dbus-glib >= @DBUS_GLIB_MINIMUM@
    2428
    2529Provides: %{name}
Note: See TracChangeset for help on using the changeset viewer.