Changeset 793


Ignore:
Timestamp:
Aug 18, 2006, 7:10:40 PM (15 years ago)
Author:
joshe
Message:

Detect if a newer compiler is needed on BeOS.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/configure

    r755 r793  
    88SYSTEM=
    99BEOS_NETSERVER=no
     10BEOS_OLDCC=no
    1011MATH=no
    1112PTHREAD=no
     
    257258        ;;
    258259    esac
     260    GCCVER=`$CC --version`
     261    case $GCCVER in
     262      2.95.3*|3*|4*)
     263        ;;
     264      2.9*)
     265        BEOS_OLDCC=yes
     266        ;;
     267      *)
     268        echo "Unsupported gcc version"
     269        exit 1
     270        ;;
     271    esac
    259272    ;;
    260273
     
    302315  openssl_test
    303316fi
     317if [ "$OPENSSL" = no ] && [ "$BEOS_OLDCC" = yes ]; then
     318  echo "built-in SHA1 implementation not supported with your gcc version"
     319  echo "you must either install OpenSSL or gcc 2.95.3 or newer"
     320  exit 1
     321fi
    304322
    305323#
Note: See TracChangeset for help on using the changeset viewer.