Opened 16 years ago

Closed 15 years ago

#102 closed Defect (worksforme)

Changing seeding status doesn't affect active torrents

Reported by: johan Owned by: somebody
Priority: Normal Milestone: Sometime
Component: Transmission Version: 0.6
Severity: Minor Keywords: seeding torrent change status
Cc:

Description

When changing seeding ratio (through the bottom left menu on transmissions window), active torrents doesn't get these new rules applied. For example:

  • Sharing a torrent with 1.05 ratio and setting a ratio of 1 doesn't make it stop sharing
  • If a torrent is done (meeting it's ratio, say 1) and raising the ratio (say 1.5) doesn't make sharing start again

Maybe this is the intended behaviour - if that's the case, please close. I haven't tried trunk either, so if it's fixed - close :)

Change History (4)

comment:1 Changed 16 years ago by livings124

For your second point this is the intended behavior, as once a torrent stops it stays stopped.

For the first point, it should stop, assuming the torrent is set to follow the global setting (the action button in the main window only applies to the global setting). Is the torrent seeding and set to follow the global setting in the inspector?

comment:2 Changed 16 years ago by johan

this is how it was set up:

  1. global setting: 1.0
  2. i raised ratio (through action menu) to 1.5
  3. started sharing the torrent
  4. changed back to global setting
  5. still seeding

comment:3 Changed 16 years ago by livings124

When you use the inspector on this transfer, in the options tab which "stop seeding" setting is enabled. If it's not "global setting" then that would explain it.

comment:4 Changed 15 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

No response and haven't heard more reports of this, so I'll assume it's working. Reopen if I'm wrong.

Note: See TracTickets for help on using tickets.