Opened 12 years ago

Closed 12 years ago

#1029 closed Bug (fixed)

When removing local data only remove data from the torrent

Reported by: Waldorf Owned by: charles
Priority: Low Milestone: 1.50
Component: Transmission Version: 1.21
Severity: Minor Keywords:
Cc:

Description

From the forum: http://forum.transmissionbt.com/viewtopic.php?t=4441
eg. when a downloaded folder contains unachieved data, don't don't delete it.

Attachments (1)

util.diff (2.1 KB) - added by michielbuddingh 12 years ago.
Ugly fix for the gtk client.

Download all attachments as: .zip

Change History (20)

comment:1 Changed 12 years ago by livings124

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 12 years ago by livings124

  • Priority changed from Low to Lowest
  • Severity changed from Normal to Minor

comment:3 Changed 12 years ago by charles

  • Component changed from Mac Client to Transmission
  • Owner livings124 deleted

comment:4 Changed 12 years ago by WouterBolsterlee

  • Priority changed from Lowest to Normal
  • Severity changed from Minor to Critical
  • Type changed from Enhancement to Bug
  • Version changed from 1.21 to 1.34+

Urgh. This just bit me really hard. I had serious data loss because Transmission irrevokably removed files it had nothing to do with in the first place.

Transmission removed all .ogg files I created from a few .flac files I downloaded. Wasted time downloading, wasted time seeding, wasted time converting, wasted time tagging those files. This is not a minor issue, but a critical one since it causes data loss.

I like Transmission a lot, but this is really annoying. I can start over all again. I'm really pissed about this right now—sorry for the harsh comments.

comment:5 Changed 12 years ago by WouterBolsterlee

Even if this is considered "not a bug", which I would strongly disagree with, there really should be a warning dialog to tell me that the directory contains extra files.

comment:6 Changed 12 years ago by livings124

  • Priority changed from Normal to Lowest
  • Severity changed from Critical to Minor
  • Version changed from 1.34+ to 1.21

While this is a problem, if you're downloading a folder and then tell the app to remove the folder, it's going to remove the folder. Plus this is why it moves it to the trash instead of deleting right away.

That warning dialog is an interesting idea, though.

comment:7 Changed 12 years ago by WouterBolsterlee

  • Priority changed from Lowest to Normal
  • Severity changed from Minor to Critical

Sorry for the severity ping pong, but this is simply not ok.

> if you're downloading a folder and then tell the app to remove the folder

The whole point is that I do not tell the application to remove my folder. I tell it to remove the torrent and the files that belong to it. The relevant UI messages are:

msgid "_Delete Files and Remove"
msgid "Delete this torrent's downloaded files?"

(Note: I'm using Transmission in another locale.)

Nothing here seems to indicate Transmission is going to remove files it doesn't own. Hence this is just a data loss bug, which is always considered critical (at least in the Gnome world where I come from).

comment:8 Changed 12 years ago by wvholst

This is unacceptable from the end user's perspective. It is not presented to the end user as removal of a folder, but removal of the torrent data. Especially with the amount of braindead RAR's put in torrents, it is perfectly normal to unpack those in the torrent's folder. Removal of the torrent does not imply removal of the unpacked data. Transmission should at least provide a warning about this. Truly elegant design, meaning design in line with what is normal on Mac would just delete the torrent files and would not touch data other than that.

comment:9 follow-ups: Changed 12 years ago by WouterBolsterlee

An example to illustrate my point: If I download a Torrent which does not contain a directory and save it to my home directory, and remove the torrent from transmission, MY COMPLETE HOME DIRECTORY CONTENTS WILL BE REMOVED.

Seriously, if you still think this can not be considered a critical bug...

Example torrent without a directory: http://cdimage.debian.org/cdimage/lenny_di_rc1/i386/bt-cd/debian-testing-i386-netinst.iso.torrent

comment:10 Changed 12 years ago by WouterBolsterlee

> Plus this is why it moves it to the trash instead of deleting right away.

I think this only works reliably for files inside $HOME, since trash support is not guaranteed for anything but $HOME afaik.

comment:11 in reply to: ↑ 9 Changed 12 years ago by livings124

Replying to WouterBolsterlee:

An example to illustrate my point: If I download a Torrent which does not contain a directory and save it to my home directory, and remove the torrent from transmission, MY COMPLETE HOME DIRECTORY CONTENTS WILL BE REMOVED.

You are wrong. Only the file you downloaded would be removed.

comment:12 Changed 12 years ago by livings124

  • Priority changed from Normal to Low
  • Severity changed from Critical to Minor

I already said a warning is a good idea and this ticket is still open. You're getting us nowhere with your redundant and melodramatic posts.

comment:13 in reply to: ↑ 9 Changed 12 years ago by charles

Replying to WouterBolsterlee:

An example to illustrate my point: If I download a Torrent which does not contain a directory and save it to my home directory, and remove the torrent from transmission, MY COMPLETE HOME DIRECTORY CONTENTS WILL BE REMOVED.

I think this is incorrect. Could you create a test user on your system and test this to confirm, please?

comment:14 Changed 12 years ago by livings124

[7153] shows a warning dialog on the Mac version.

Changed 12 years ago by michielbuddingh

Ugly fix for the gtk client.

comment:15 in reply to: ↑ 9 ; follow-up: Changed 12 years ago by charles

Replying to WouterBolsterlee:

An example to illustrate my point: If I download a Torrent which does not contain a directory and save it to my home directory, and remove the torrent from transmission, MY COMPLETE HOME DIRECTORY CONTENTS WILL BE REMOVED.

Seriously, if you still think this can not be considered a critical bug...

Example torrent without a directory: http://cdimage.debian.org/cdimage/lenny_di_rc1/i386/bt-cd/debian-testing-i386-netinst.iso.torrent

Did you ever get around to testing whether or not this was true?

comment:16 in reply to: ↑ 15 Changed 12 years ago by WouterBolsterlee

Replying to charles:

Did you ever get around to testing whether or not this was true?

Yes, and it seems it's not true, but I didn't have my Trac password at that time. Sorry for the late response.

Yet I think Transmission should never delete data it is not supposed to manage, not even with a big fat warning. The warning is just a work-around for the underlying problem, which is not 'minor' in my opinion.

— Wouter (not as annoyed as I was a while back ;))

comment:17 Changed 12 years ago by livings124

For the Mac client at least, the current show-warning solution I think is the best, as there's no simple way to divide a folder's contents up and retain its layout. If you treat each transfer as sending the folder itself, as opposed to its contents, then this solution makes perfect sense.

comment:18 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.50
  • Owner set to charles
  • Status changed from new to assigned

Added to trunk for libtransmission and gtk+ client in r7473

comment:19 Changed 12 years ago by livings124

  • Resolution set to fixed
  • Status changed from assigned to closed

Added to trunk for mac client in r7484

Note: See TracTickets for help on using tickets.