Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1031 closed Bug (invalid)

TR not working with latest glib

Reported by: infernux Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.21
Severity: Normal Keywords:
Cc:

Description

Transmission does not seem to work correctly with the latest (unstable) glib release. If you add a torrent, no files are shown and you cannot add it. The console prints the following errors:

(transmission:19700): GLib-GObject-CRITICAL : g_object_ref: assertion `G_IS_OBJECT (object)' failed

(transmission:19700): GLib-GObject-CRITICAL : g_object_unref: assertion `G_IS_OBJECT (object)' failed

(transmission:19700): GLib-GObject-CRITICAL : g_object_ref: assertion `G_IS_OBJECT (object)' failed

(transmission:19700): GLib-GObject-CRITICAL : g_object_unref: assertion `G_IS_OBJECT (object)' failed

Change History (4)

comment:1 Changed 13 years ago by mezz

It will be great if you can tell us what version or revision number of SVN. You never know if it's a new bug in glib or something that can help developers to locate the problem quicker. Is it glib 2.17.2?

comment:2 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

I'm not able to reproduce this with glib 2.17.2, so there's not anywhere for me to go with this unless more information is added. A backtrace would also be helpful.

comment:3 Changed 13 years ago by infernux

Sorry, I meant to include that info but forgot. I'm running a post-2.17.2 snapshot here (r7042). Should I reopen the bug if it still happens when .3 is out?

comment:4 Changed 13 years ago by livings124

We can't support prerelease versions of other's software.

Note: See TracTickets for help on using tickets.