Opened 13 years ago

Closed 13 years ago

#1033 closed Enhancement (wontfix)

Use the system-wide proxy on OS X

Reported by: tiennou Owned by:
Priority: Lowest Milestone: None Set
Component: Mac Client Version: 1.22+
Severity: Normal Keywords:
Cc:

Description

I had to switch to using tor in order to circumvent the blocakde on .torrent files instated by my ISP, and I had a thought about the recent proxy support added ;-).

The problem is that I want proxying only at home (and thus has enabled the system-wide proxy under this network configuration only), and since Transmission repeats the proxy configuration in its prefs, I can't have the benefits of automagically enabling/disabling the proxy when I change network configurations.

Change History (7)

comment:1 Changed 13 years ago by tiennou

  • Version changed from 1.22 to 1.22+

comment:2 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

What the proxy GUI does, is force a specific configuration onto libcurl. If you disable the proxy in Transmission's GUI, then Transmission will fall back to the standard http_proxy, ftp_proxy, all_proxy etc environmental variables, if any of those is set.

So I think all you need to do is to disable the proxy in Transmission's GUI, and just use the standard environmental variables.

comment:3 Changed 13 years ago by charles

As an aside, it's nice to hear from you again. :)

comment:4 Changed 13 years ago by tiennou

Agreed, it's been a long time ;-). I hope I'll be able to devote a little more time in helping T's development (I'm overloaded by work atm), but expect to have a nice DHT working in a few months from now, and a quick patch for fixing fast-peers ! Keep up the good work !

comment:5 Changed 13 years ago by tiennou

  • Priority changed from Normal to Lowest
  • Resolution invalid deleted
  • Status changed from closed to reopened

I tested it right now (with wireshark), and it doesn't work (I still see HTTP traffic with announce in them). Guess Apple doesn't like environment variables ;-). Lowering priority, since its a small issue.

comment:6 Changed 13 years ago by charles

  • Component changed from Transmission to Mac Client

comment:7 Changed 13 years ago by livings124

  • Resolution set to wontfix
  • Status changed from reopened to closed

The proxy support is just for the the tracker connection separate from the system. If you can write a patch for that to go through the system settings separately, please reopen.

Note: See TracTickets for help on using tickets.