Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1038 closed Bug (invalid)

Transmission SVN fails autogen.sh on Ubuntu

Reported by: smmalis Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.22+
Severity: Normal Keywords:
Cc:

Description

Not sure if this is my bug or yours, but upon running autogen.sh, I get the following:

configure.in:27: error: possibly undefined macro: AC_PROG_LIBTOOL
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
autoreconf: /usr/bin/autoconf failed with exit status: 1
Creating aclocal.m4 ...
Running glib-gettextize...  Ignore non-fatal messages.
Copying file mkinstalldirs
Copying file po/Makefile.in.in

Please add the files
  codeset.m4 gettext.m4 glibc21.m4 iconv.m4 isc-posix.m4 lcmessage.m4
  progtest.m4
from the /aclocal directory to your autoconf macro directory
or directly to your aclocal.m4 file.
You will also need config.guess and config.sub, which you can get from
ftp://ftp.gnu.org/pub/gnu/config/.

Making aclocal.m4 writable ...
Running intltoolize...
Running ./configure --enable-maintainer-mode all
autogen.sh: 46: ./configure: not found

Now type 'make' to compile Transmission.
./installdev-transmission: line 5: ./configure: No such file or directory
make: *** No targets specified and no makefile found.  Stop.

I have seen this bug on many message boards, but nobody has a solution. Attached is the script I use. Any ideas?

Attachments (1)

installdev-transmission (393 bytes) - added by smmalis 13 years ago.
Script to create .deb of latest SVN Transmission (in theory)

Download all attachments as: .zip

Change History (3)

Changed 13 years ago by smmalis

Script to create .deb of latest SVN Transmission (in theory)

comment:1 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

You need to install libtool.

comment:2 Changed 13 years ago by smmalis

This should be mentioned on the Development page, as I am not the only one experiencing this problem.

Note: See TracTickets for help on using tickets.