Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1049 closed Bug (invalid)

Proxy Authorisation Fails (error: 407)

Reported by: Waldorf Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.30
Severity: Normal Keywords:
Cc: pea

Description

I've been testing the proxy support and noticed that the authentication doesn't seem to do anything. Same settings in the system proxy do work. Without authentication it did work though. All I'm getting is the 407 error, saying I need to authenticate.

I could not find an issue on the mac side, so setting this to libT.

Change History (13)

comment:1 Changed 13 years ago by Waldorf

For testing, talk to pea_.

comment:2 follow-up: Changed 13 years ago by charles

I don't understand this ticket. Could you give more details?

Are you talking about authentication for RPC? You're using a proxy RPC connections??

comment:3 in reply to: ↑ 2 Changed 13 years ago by Waldorf

Replying to charles:
No, not at all. I'm talking about proxy (you know, for the tracker communication).
Since I was testing the (http) proxy with pea, I noticed it didn't matter wether I authenticated (entered name and password for the proxy) or not, I got the 407 error nonetheless.
The same proxy server + authentication works perfect in osx.

comment:4 Changed 13 years ago by Waldorf

  • Cc pea added

comment:5 Changed 13 years ago by charles

Is this still an issue?

comment:6 Changed 13 years ago by charles

Waldorf: ping

comment:7 Changed 13 years ago by livings124

from pea in irc:

this is that T fails authenticate if password protected HTTP proxy for tracker is used (the same proxy works fine for web browser)

comment:8 Changed 13 years ago by muks

I can't reproduce this issue with basic authentication.

Haven't tried it with Digest and other authentication forms.

comment:9 Changed 12 years ago by charles

  • Version changed from 1.22+ to 1.30

comment:10 Changed 12 years ago by charles

Is this still an issue?

comment:11 Changed 12 years ago by Waldorf

  • Resolution set to invalid
  • Status changed from new to closed

Because of lack of information, and the fact that proxy is part of the libcurl lib, I'm closing the ticket.

comment:12 follow-up: Changed 12 years ago by Xmas_Beetle

perhaps "proxy-auth-password": "",(from $HOME/.config/transmission/settings.json) even though a password is set via the GTK client??

comment:13 in reply to: ↑ 12 Changed 12 years ago by Xmas_Beetle

Replying to Xmas_Beetle:

perhaps "proxy-auth-password": "",(from $HOME/.config/transmission/settings.json) even though a password is set via the GTK client??

Sorry a little more info... When the proxy password is updated via the GTK client, "rpc-password": "theproxypasshere", in the config file.

Manually updating proxy-auth-password is reset to "" after a restart of the client.

Note: See TracTickets for help on using tickets.