Opened 13 years ago

Closed 13 years ago

#1052 closed Bug (fixed)

intltool 0.40.0 fails to configure

Reported by: oleo Owned by: charles
Priority: Low Milestone: 1.30
Component: Transmission Version: 1.22
Severity: Minor Keywords:
Cc:

Description

libtoolize 0.40 fails to create files intltool-extract.in intltool-merge.in intltool-update.in when running autogen.sh

Using libtool 0.35 works well.

Last lines of configure shows the problem:

checking pkg-config is at least version 0.9.0... yes
checking for OPENSSL... yes
checking for LIBCURL... yes
checking for special C compiler options needed for large files... no
checking for _FILE_OFFSET_BITS value needed for large files... 64
checking how to copy va_list... va_copy
configure: invoking libevent's configure script
checking for GTK... no
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for intltool >= 0.23... awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
awk: cmd. line:1: fatal: cannot open file `./intltool-update.in' for reading (No such file or directory)
 found
./configure: line 24144: test: : integer expression expected
configure: error: Your intltool is too old.  You need intltool 0.23 or later.

Change History (7)

comment:1 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Surely this should be reported upstream to intltool. Unless Transmission is incorrectly using the tool, this isn't a Transmission problem.

Conversely, if the intltool people *do* have a recommendation for changes to Transmission's configure/make system, please reopen this ticket.

comment:2 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 1.22+ to 1.22

Hm, I think this is a Transmission issue after all. I think the problem is that Transmission is picking up intltool macros from the m4/ directory rather than from the OS, so when there's shear between the two sources, users get bitten.

Probably the m4/ directory's intltool macros should go away.

comment:3 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

removed in r6284.

comment:4 Changed 13 years ago by charles

  • Milestone changed from 1.40 to 1.30

comment:5 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by charles

  • Owner set to charles
  • Status changed from reopened to new

comment:7 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.