Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1077 closed Enhancement (duplicate)

Prioritization among torrents

Reported by: djihed Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.22
Severity: Normal Keywords:
Cc:

Description (last modified by livings124)

Currently, files within a torrent can be prioritised. This is a very good feature.

I have got a few more suggestions within this:

X 1) Point based prioritisation: instead of the current 3 way scale (high, normal, low), give a 0 to 100 weight to each file.

X 2) Auto prioritisation based on file list. For example: Attempt to prioritise first file in the list, then second etc

3) It would also be very good to add prioritisation of whole torrents. If this is present, I'm not aware of it; e.g. torrent #1 higher than torrent #2.

Change History (11)

comment:1 follow-up: Changed 13 years ago by charles

(1) has been discussed in the past, but the consensus seems to be that it's an overcomplicated way of doing things.

(2) is not going to happen, for the same reason we're not downloading pieces in order from first to last. Search the forums for more information on that.

(3) is not a bad idea. :)

comment:2 Changed 12 years ago by livings124

  • Description modified (diff)
  • Summary changed from Ability to prioritise between torrents + finer prioritisation to Prioritization among torrents

comment:3 Changed 12 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

#1943 is a more-detailed ticket for this.

comment:4 Changed 12 years ago by charles

ticket #2303 has been closed as a duplicate of this ticket.

comment:5 in reply to: ↑ 1 Changed 12 years ago by shiretu

Replying to charles:

(1) has been discussed in the past, but the consensus seems to be that it's an overcomplicated way of doing things.

My opinion is that is worth trying. Im'm also a open source developer and when 3-4 users are requesting the same thing, it rings a big bell for me. And is not overcomplicated. I think sharing bandwidth (with scale factor of low,normal,high) is much more complicated that downloading one file at a time in a particular order.

(2) is not going to happen, for the same reason we're not downloading pieces in order from first to last. Search the forums for more information on that.

I think you should offer this functionality too. If that is possible, than we can watch the movies as they download because the file is completed from start to end, not sparse.

(3) is not a bad idea. :)

comment:6 follow-up: Changed 12 years ago by livings124

Bad ideas. 100 levels of priority is overkill, especially since you aren't guaranteed that order.

Sequential downloading is also horrible: http://forum.transmissionbt.com/viewtopic.php?f=3&t=7792&p=37742&hilit=sequential#p37746

comment:7 in reply to: ↑ 6 Changed 12 years ago by shiretu

My knowledge about the protocol is minimal. Nevertheless, I do what I've described before manually and it seems to work great. For example, I dld. a tv series. The torrent contains separate file for each episode. I deliberately select the first episode for downloading and deselect the others. After is finished, I start watch the episode. In the mean time, I select the next episode for download. The rest are still deselected. I'm not interested in downloading the episode 30 when I'm still watching episode 1. Is useless. I do agree that proceeding in the same manner with the little chunks inside a file is an overkill. We are talking here about the files in a torrent not the pieces in the file. If there is no separation between pieces from a file and files in torrent than you already overkill the swarm by providing means of selecting/deselecting the files inside a torrent. At least it would be great to download the files in a certain order, not all of them at once.

comment:8 Changed 12 years ago by livings124

Did you read the links in the thread I posted?

comment:9 Changed 12 years ago by shiretu

Yes, I've read the posts, I understand that this hurts the swarm pretty much, but you already provide means of hurting the swarm: you give us the opportunity to (not) download certain files in a torrent. IMHO you either remove it or make it play nice with the users's needs: be able to download them in certain order. Again, Im talking about the files in the torrent not the pieces in a file.

Some time ago, Guy Kawasaki spoken: "Let the people pervert your product". WE (you,me, them) must bend the protocol to our needs, not letting the protocol bend us. If so many people is asking for it, don't you think it would be a great idea to implement it? We already use it the way we want (manually activate/deactivate files). Why not implementing it and let the users enjoy it!?

I fail to understand...

Thank you for your support

comment:10 follow-up: Changed 12 years ago by livings124

True, if people deselect files, they will not be sharing that part. But downloading in order will completely destroy the swarm. Those posts all explain why in detail.

I'll just have to say that you should design a protocol without this flaw.

comment:11 in reply to: ↑ 10 Changed 12 years ago by Siker

Replying to livings124:

True, if people deselect files, they will not be sharing that part. But downloading in order will completely destroy the swarm. Those posts all explain why in detail.

That may be true for certain swarms but not always. The swarms I participate in are brimming with seeders and there are rarely any leechers. In this situation it doesn't matter if you download the contents forward, arbitrarily or rarest first. Transmission's file priority system could be upgraded to detect this situation and act on it easily. The rule could succintly be described as this:

If there is a choice between a high priority piece and a low priority piece and there are at least X seeders available for both, always pick the high priority piece.

This would resolve my problem - high priority files would always go before low priority files in my super seeded case. Meanwhile, the kind of torrent livings124 is concerned about where seeders are scarce would automatically fall back on the 'preserve least common pieces first' mentality. You could call this 'glut mode' vs 'starvation mode'.

As it stands right now the per file priority system doesn't work in an intuitive way. You can deprioritize every file except one in a torrent and still end up with much of the overall torrent down before you get that one file. This is rather painful if the torrent is 60GB and the file you want is 0.5GB and people are throwing data at you as fast as your connection can take it. It really feels like you should get that file fast but it just endlessly creeps towards completion at no significantly faster rate than the rest of the files.

Note: See TracTickets for help on using tickets.