Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1084 closed Enhancement (fixed)

Make `web' and `clutch' resolve identically in libtransmission

Reported by: mezz Owned by: charles
Priority: Normal Milestone: 1.30
Component: Transmission Version: 1.22+
Severity: Normal Keywords:


I do realized that it's incomplete and web directory was added recently. I just want to create a new ticket to make suggest in case. By the way, in both libtransmission/platform.c and libtransmission/rpc-server.c are looking for $(datadir)/transmission/clutch, while it's transmission/web now.

I think it's possible best to rename a few from clutch to web, the 'clutch' isn't clear for new developers/users. Like for example: clutchDir -> webDir, tr_getClutchDir -> tr_getWebDir, CLUTCH_HOME -> WEB_HOME (maybe TRWEB_HOME or better name) and goes on. What do you think?

While I am here. I am maintaining transmission packages in FreeBSD. We have transmission, transmission-daemon and transmission-gtk2. I am planning to move from transmission to transmission-cli and create a new package for web called transmission-web. Have all other transmission-* to have runtime dependency on transmission-web. Unless you have any better suggest? I haven't play with cli yet, but does cli has remote access option? If not, then it won't be depend on transmission-web.

Change History (4)

comment:1 follow-up: Changed 13 years ago by charles

  • Milestone changed from None Set to 1.30
  • Summary changed from Rename from clutch to web in a few places.. to Make `web' and `clutch' resolve identically in libtransmission
  • Type changed from Bug to Enhancement

There are two sides to this: first, it definitely is less confusing to use the name web' than clutch', since the former is more descriptive to new users. The other side to this is that the Clutch developers like its name, so that name is here to stay.

I think we can have our cake and eat it too on this one. On the web URL, we can have transmission/clutch/ and transmission/web/ resolve to the same place. Similarly we can honor both TRANSMISSION_WEB_HOME and CLUTCH_HOME in platform.c.

comment:2 Changed 13 years ago by charles

  • Owner set to charles
  • Status changed from new to assigned

comment:3 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r6328.

comment:4 in reply to: ↑ 1 Changed 13 years ago by mezz

Thanks, the TRANSMISSION_WEB_HOME is a lot better! Easier for me to know what stuff are in my ~/.zshrc. ;-)

Replying to charles:

The other side to this is that the Clutch developers like its name, so that name is here to stay.

I am not asking to rename actually WebUI, just stuff that are in core mostly like tr_getClutchDir -> tr_getWebDir for example. :-) But it's not a big deal when I know what Clutch is.

Note: See TracTickets for help on using tickets.