Opened 13 years ago

Closed 13 years ago

#1089 closed Bug (fixed)

Extended characters in torrent's filenames come out wrong

Reported by: andersos Owned by: muks
Priority: Normal Milestone: 1.33
Component: libtransmission Version: 1.30
Severity: Normal Keywords:
Cc:

Description

I added some torrents that contain filenames with extended characters in them with transmission-remote. Resulting filenames that Transmission want to use aren't correct - transmission-remote outputs debug info (Unable to parse response) that shows file name as T is going to write it. Is T fully utf-8 compatible?

For example t-r debug output shows 2\uc2\ubd instead of 2½ (two and a half), and the file name on disk looks strange.

Everything about the torrents look ok on my nas, from torrent name to file names when I open torrent in nano.

Change History (7)

comment:1 Changed 13 years ago by charles

  • Version changed from 1.22+ to 1.30

comment:2 Changed 13 years ago by charles

  • Summary changed from Extended characters in filenames within torrents doesn't come out right to Extended characters in torrent's filenames come out wrong

comment:3 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.33
  • Owner changed from SoftwareElves to charles

comment:4 Changed 13 years ago by charles

  • Component changed from Daemon to libtransmission
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by charles

  • Owner changed from charles to muks
  • Status changed from reopened to new

comment:7 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.