Opened 13 years ago

Closed 13 years ago

#1126 closed Bug (fixed)

crash on quit

Reported by: persept Owned by: charles
Priority: Normal Milestone: 1.30
Component: libtransmission Version: 1.22
Severity: Normal Keywords:
Cc:

Description

crashlog is attatched

Attachments (2)

crash on quit r6420.txt (29.2 KB) - added by persept 13 years ago.
crash on quit r6421.txt (31.9 KB) - added by persept 13 years ago.

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by persept

comment:1 Changed 13 years ago by charles

  • Component changed from Transmission to libtransmission
  • Milestone changed from None Set to 1.30
  • Owner set to charles
  • Status changed from new to assigned

I've checked in a probable fix for this in r6421, but since I can't reproduce the bug anyway I'll need you to reopen this ticket if the problem persists.

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Changed 13 years ago by persept

comment:3 Changed 13 years ago by persept

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 13 years ago by persept

One thing that seems to be happening is this: So transmission has been running for a while. I add a new torrent, but it doesn't get any peers from the tracker. ?'s show up there as if it hasn't been able to contact the tracker, but there's no error that shows up in transmission that says it cannot contact the tracker. Then when I try to quit Transmission, it crashes on quit. When I restart it, those torrents get peers again.

comment:5 Changed 13 years ago by charles

There should be an assertion failure message that corresponds to that second crash. Could you post it here please?

comment:6 Changed 13 years ago by persept

I'm not sure how to get that... Any ideas?

comment:7 Changed 13 years ago by charles

I think I found it; give r6424 a spin...

comment:8 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

as always, feel free to reopen...

Note: See TracTickets for help on using tickets.