Opened 13 years ago

Closed 13 years ago

#1142 closed Bug (fixed)

Transmission 1.22: High CPU usage in evbuffer_expand

Reported by: dieymir Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.22
Severity: Major Keywords:
Cc:

Description

Hello,

I have noticed that, after some hours running, Transmission starts to use a lot of CPU (almost 100%). I have used sysprof to profile the application and it seems that the offending function is evbuffer_expand.

The version I'm using is 1.22, but also happens with older versions, I cannot test 1.30b3 because I'm using an old version of libcurl and I cannot compile it.

Transmission was compiled on Slackware 12.1 with -march=i586 and -mtune=i686 gcc options.

I saved the sysprof session on the attached file.

Attachments (1)

transmission.gz (66.1 KB) - added by dieymir 13 years ago.
Sysprof saved data

Download all attachments as: .zip

Change History (5)

Changed 13 years ago by dieymir

Sysprof saved data

comment:1 Changed 13 years ago by charles

Does this persist in 1.30?

comment:2 Changed 13 years ago by charles

dieymir: ping

comment:3 Changed 13 years ago by dieymir

I'm currently testing 1.32. So far I cannot reproduce the problem, maybe is fixed yet. I'll continue testing.

comment:4 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

sounds good to me. I'm going to close this ticket for now but feel free to reopen as needed. :)

Note: See TracTickets for help on using tickets.