Opened 13 years ago

Closed 13 years ago

#1153 closed Bug (fixed)

Transmission exits while changing login settings for the Web Client

Reported by: f4hy Owned by: charles
Priority: Normal Milestone: 1.40
Component: libtransmission Version: 1.31
Severity: Normal Keywords: Web Client
Cc:

Description

Transmission exits out while setting the username and password for the web client. Going to the web tab of preferences, and typing a user name an password closes transmission completely without warning. It does not happen immediately and the characters entered so far for the username and pass are saved for the next time transmission is loaded.

Running from the terminal I get this message on crash: open_listening_port(9091): Address already in use cannot open port 9091

Attachments (1)

config.log (62.0 KB) - added by f4hy 13 years ago.
config.log from ./configure

Download all attachments as: .zip

Change History (7)

comment:1 Changed 13 years ago by charles

I can't reproduce this in the gtk+ client.

f4hy, were you using the mac or gtk+ client?

Changed 13 years ago by f4hy

config.log from ./configure

comment:2 Changed 13 years ago by f4hy

I am using the gtk+ client in gnome on Ubuntu 8.04.1 I attached config.log from the compile.

This evening I will try changing the port to something else although a netstat did not show anything open on port 9091.

Even if the port is open the app should not close out when the port is in use but should display some message. Ill try to get a better report on how to recreate it

comment:3 Changed 13 years ago by f4hy

  • Component changed from Transmission to Web Client
  • Owner set to Gimp

Changing the web client to a different port fixes the problem.

However it still quits completely out if the web client is set to 9091. I am unsure of what else I have open on that port but either way port conflicts with the web client should not kill transmission completely.

comment:4 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40
  • Owner changed from Gimp to charles
  • Status changed from new to assigned

the recent swap in trunk from shttp to evhttp seems to have fixed this as a happy side-effect.

comment:5 Changed 13 years ago by charles

  • Component changed from Web Client to libtransmission

comment:6 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.