Opened 13 years ago

Closed 13 years ago

#1156 closed Bug (fixed)

Crash when removing a torrent through web interface

Reported by: bm3x Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.32
Severity: Major Keywords:
Cc:

Description

Removing a torrent through the web interface crashes Transmission on OS X. Happens both on Safari Mac and iPhone.

Change History (5)

comment:1 Changed 13 years ago by charles

I can't duplicate this. Could you attach the Transmission crash report and also any assertion message that might be associated with it?

See item #6 at http://forum.transmissionbt.com/viewtopic.php?f=1&t=3274 for an explanation on how to get the crash report and assertion messages...

comment:2 Changed 13 years ago by bm3x

I did some more tests and it's actually semi-random on a PowerPC (iMac 17" 1.25) and it doesn't seem to happen at all on intel (MacBook? Pro). I could be a endian issue, or maybe a race condition?

I'll check the logs if I find anything, but the crashes are actually quite hard, with transmission not even quitting immediately but hanging for a few seconds...

comment:3 Changed 13 years ago by bm3x

  • Version changed from 1.31 to 1.32

Happened again.

I removed one torrent without issues, then the 2nd crashed.

Actually it was still showing up in the native GUI with bogus info like size of 4 294 967 296 bytes... then it crashed.

Process: Transmission [9955] Path: /Applications/Transmission?.app/Contents/MacOS/Transmission Identifier: org.m0k.transmission Version: 1.32 (6453) Code Type: PPC (Native) Parent Process: launchd [506]

Date/Time?: 2008-08-11 11:28:35.226 +0200 OS Version: Mac OS X Server 10.5.4 (9E17) Report Version: 6

Exception Type: EXC_BAD_ACCESS (SIGSEGV) Exception Codes: KERN_INVALID_ADDRESS at 0x000000005550875c Crashed Thread: 0

Thread 0 Crashed: 0 libSystem.B.dylib 0x90059b88 strlen + 8 1 com.apple.Foundation 0x9268ec9c +[NSString stringWithUTF8String:] + 96 2 org.m0k.transmission 0x0001db48 -[Torrent closeRemoveTorrentInterface] + 40 3 org.m0k.transmission 0x0001dbb4 -[Torrent closeRemoveTorrent] + 28 4 org.m0k.transmission 0x00006a7c -[Controller confirmRemoveTorrents:deleteData:deleteTorrent:fromRPC:] + 336 5 org.m0k.transmission 0x000068fc -[Controller removeSheetDidEnd:returnCode:contextInfo:] + 172 6 com.apple.AppKit? 0x9379b308 -[NSAlert didEndSheet:returnCode:contextInfo:] + 188 7 com.apple.AppKit? 0x93747180 -[NSAlert buttonPressed:] + 244 8 com.apple.AppKit? 0x935d20dc -[NSApplication sendAction:to:from:] + 104 9 com.apple.AppKit? 0x935d2010 -[NSControl sendAction:to:] + 92 10 com.apple.AppKit? 0x935d1528 -[NSCell trackMouse:inRect:ofView:untilMouseUp:] + 1584 11 com.apple.AppKit? 0x935d0e60 -[NSButtonCell trackMouse:inRect:ofView:untilMouseUp:] + 516 12 com.apple.AppKit? 0x935d079c -[NSControl mouseDown:] + 804 13 com.apple.AppKit? 0x935cf060 -[NSWindow sendEvent:] + 4512 14 com.apple.AppKit? 0x935a2404 -[NSApplication sendEvent:] + 3256 15 com.apple.AppKit? 0x9350f6f4 -[NSApplication run] + 776 16 com.apple.AppKit? 0x934e00d0 NSApplicationMain + 440 17 org.m0k.transmission 0x00003240 main + 116 18 org.m0k.transmission 0x0000319c _start + 744 19 org.m0k.transmission 0x00002eac start + 44 20 ??? 0x00000ffc 0 + 4092

comment:4 Changed 13 years ago by charles

  • Component changed from Web Client to Mac Client
  • Owner changed from Gimp to livings124

bm3x: thanks for the backtrace. :)

comment:5 Changed 13 years ago by livings124

  • Resolution set to fixed
  • Status changed from new to closed

[6511] should hopefully fix this, but I can't reproduce it so I can't test it. Please reopen if this still occurs.

Note: See TracTickets for help on using tickets.