Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1165 closed Bug (duplicate)

r6466 crash before visible window GTK+ gdb bt

Reported by: Lacrocivious Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.32+
Severity: Normal Keywords:
Cc:

Description

svn co to clean sandbox; build with ./autogen.sh, make

Launch using gdb; program window never appears before segfault. Fedora Core 4

http://pastebin.ca/1097391

Change History (4)

comment:1 Changed 13 years ago by Lacrocivious

This debug log may be useful.

http://pastebin.ca/1097414

Created with:

export TRANSMISSION_HOME=/temporary/testingdir export TR_DEBUG_FD=2 /usr/local/Transmission-1x/gtk/transmission 2>transmission-r6466-fc4-debug.log

Only one torrent was in testingdir. Transmission loaded with torrent paused, allowed me to verify version via help dialog. Closed help/about dialog. Click-selected torrent. Clicked Start. Program segfaulted and vanished.

comment:2 Changed 13 years ago by Lacrocivious

  • Version changed from 1.32 to 1.32+

comment:3 Changed 13 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1164, but the backtrace is helpful :)

comment:4 Changed 13 years ago by charles

Lacrocivious: as a side note, in the future please attach backtraces & debug logs as plaintext attachments to the ticket, rather than links to an offsite pastebin. Thanks.

Note: See TracTickets for help on using tickets.