Opened 13 years ago

Closed 13 years ago

#1175 closed Bug (fixed)

Add missing va_end()s

Reported by: muks Owned by: muks
Priority: Normal Milestone: 1.33
Component: libtransmission Version: 1.32
Severity: Normal Keywords:
Cc:

Description

va_ends() are missing in some places where vaargs are used.

Attachments (1)

0001-Add-missing-va_end-s.patch (1.2 KB) - added by muks 13 years ago.
Patch to add missing va_end()s

Download all attachments as: .zip

Change History (10)

Changed 13 years ago by muks

Patch to add missing va_end()s

comment:1 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.33
  • Status changed from new to assigned

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

1.3x: r6479 trunk: r6480

Thanks for the patch! If you don't mind my asking, how did you find these errors? Was it by reading the code, or with a tool?

comment:3 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:4 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:5 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:7 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 Changed 13 years ago by charles

  • Owner changed from charles to muks
  • Status changed from reopened to new

comment:9 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.