Opened 13 years ago

Closed 13 years ago

Last modified 6 years ago

#1203 closed Bug (duplicate)

Mac OS X: Scrollbar not appearing or disappearing

Reported by: rlxbt Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.32
Severity: Normal Keywords:
Cc:

Description

This may happen under various conditions, but the easiest way to reproduce it is:

  • arrange a large number of transfers in multiple groups.
  • collapse all groups. the window will shrink to the required size.
  • open one group. the vertical scrollbar will not appear, even though there are more torrents in the group than fit in the window.
  • scroll with mouse wheel. scroll bar appears.

Another way to trigger it would be, after having performed the above actions, to:

  • show the previously hidden filter bar. scroll bar stays visible.
  • hide the filter bar. scroll bar disappears, even though there are still more items than fit in the window.

Change History (3)

comment:1 Changed 13 years ago by rlxbt

The above happens when the preference General -> Auto Resize is checked. See #449 for an issue that probably refers to the steps 5 and 6.

comment:2 Changed 13 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

This is all related to the issue in #449

comment:3 Changed 6 years ago by ScytheV

The scroll bar is extremely annoying, I registered the account just to upvote this. It should be taken out completely, since I guess people who use Mac don't really use scroll bars. Or there can be an option to turn it on in Preferences.

Note: See TracTickets for help on using tickets.