Opened 13 years ago

Closed 12 years ago

#1205 closed Enhancement (duplicate)

Better proxy support

Reported by: sala Owned by: charles
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.32
Severity: Normal Keywords:
Cc:

Description

Transmission daemon internal web server does not work very well with different proxy configurations.

For example transmission-daemon works only in this lighttpd proxy configuration:

proxy.server = ( "/" =>
                            (
                                     ( "host" => "127.0.0.1", "port" => 9091 )
                            )
               )

and not with this configuration:

proxy.server = ( "/torrents/" =>
                            (
                                     ( "host" => "127.0.0.1", "port" => 9091 )
                            )
               )

and this configuration will produce nasty request looping:

proxy.server = ( "/transmission/" =>
                          (
                                     ( "host" => "127.0.0.1", "port" => 9091 )
                          )
               )

Maybe it is possible to make transmission-daemon web location ("/transmission/web") more dynamic so it could work also through proxy's ("/torrents/transmission/web").

Change History (6)

comment:1 Changed 13 years ago by charles

What would you suggest?

comment:2 Changed 13 years ago by sala

I am no programmer but as far as I understand web interface location is right now /transmission/web , but if it would be ./transmission/web then it should be dynamic (it could run in any sub directory, not only from the root of your domain/ip).

comment:3 Changed 13 years ago by jidanni

I wish there was a checkbox

[X]Use $http_proxy

that I could uncheck, instead of happing to write a wrapper program to pull it out of the environment if I don't want transmission to see it.

comment:4 follow-up: Changed 13 years ago by mattm

While more flexibility around paths would be desirable, this works:

$HTTP["url"] =~ "transmission/web" {
        proxy.server = ( "" => (
        ( "host" => "127.0.0.1", "port" => 9091 )
        ))
}
$HTTP["url"] =~ "transmission/rpc" {
        proxy.server = ( "" => (
        ( "host" => "127.0.0.1", "port" => 9091 )
        ))
}

Perhaps a rewrite could allow you to change the url on the proxy side...

comment:5 in reply to: ↑ 4 Changed 13 years ago by Lafriks

While adding this works just fine but not file upload.

$HTTP["url"] =~ "transmission/rpc" {
        proxy.server = ( "" => (
        ( "host" => "127.0.0.1", "port" => 9091 )
        ))
}

comment:6 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #1538.

Note: See TracTickets for help on using tickets.