Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1210 closed Bug (fixed)

Web UI yields "Error: 404" not found if path contains a space

Reported by: livings124 Owned by: livings124
Priority: Normal Milestone: 1.34
Component: Mac Client Version: 1.33
Severity: Normal Keywords:
Cc:

Description

If the path contains a space (for any directory in the path), opening the web ui leads to a 404.

Change History (9)

comment:1 Changed 13 years ago by diamondsw

  • Component changed from libtransmission to Web Client
  • Owner changed from charles to Gimp
  • Summary changed from web ui not found if path contains a space to Web UI yields "Error: 404" not found if path contains a space

Integrating from my duplicate bug report:

When the Transmission application is placed in a directory that has a space in the full path (e.g. "/Applications/File? Transfer/BitTorrent/?"), the web interface will fail with "Error: 404". This occurs after the redirect from http://localhost:9091/ to http://localhost:9091/transmission/web/. Observed since version 1.31; still present in version 1.33. Forum thread is here: http://forum.transmissionbt.com/viewtopic.php?f=4&t=5534.

comment:2 Changed 13 years ago by charles

  • Version changed from 1.32+ to 1.33

comment:3 Changed 13 years ago by charles

This is working for me under Linux, in both the gtk+ and daemon. For the record it's trunk r6641, but I haven't made any changes to the code to handle this, so I suspect I'd get the same results on other revisions too.

Could this be an issue with how the Mac OS X client determines where the files are?

comment:4 Changed 13 years ago by livings124

  • Component changed from Web Client to Mac Client
  • Owner changed from Gimp to livings124
  • Status changed from new to assigned

Indeed, this looks to be a mac problem.

comment:5 Changed 13 years ago by livings124

  • Milestone changed from None Set to 1.40
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 13 years ago by diamondsw

Fix confirmed. Thanks!!

comment:7 Changed 13 years ago by charles

  • Keywords backport-candidate added

comment:8 Changed 13 years ago by charles

backported to 1.3x in r6752

comment:9 Changed 13 years ago by charles

  • Keywords backport-candidate removed
  • Milestone changed from 1.40 to 1.34
Note: See TracTickets for help on using tickets.