Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1218 closed Bug (invalid)

No user agent during initial handshake

Reported by: federico62 Owned by: charles
Priority: Normal Milestone: None Set
Component: libtransmission Version: 1.33
Severity: Blocker Keywords: user agent handshake header
Cc:

Description

Since version 1.11 I have been unable to connect to a specific tracker.

The connection is rejected with the error message "BT client responded, but with wrong header/hash/peerid string". Please note that this happens only with version 1.20 and above, including 1.33. Version 1.11 and below still work perfectly. The problem only arises with this specific tracker (please do not tell me to leave this tracker, because it is a real good one! I'd rather keep using version 1.11)

The tracker's staff have been contacted on this issue and they say that "the new version 1.2.0.0 of Transmission does not contain a user agent to do the initial handshake and that creates the problem."

They say that the issue should be fixed on Transmission's side. I frankly doubt it, but I would like to know if it is true and what we should tell them to fix instead.

Thank you.

Change History (2)

comment:2 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Your tracker is incorrect.

I've confirmed this firsthand in the latest version by turning on curl debugging messages and connecting to the bsd tracker:

GET /scrape?info_hash=%8EP%21%27%F3%8D%C1%BB%22%EF%C9%14%0D%3B%20Cy%7BFK HTTP/1.1
User-Agent: Transmission/1.33+ (6623)
Host: torrents.freebsd.org:8080
Accept: */*
Accept-Encoding: deflate, gzip

This has been confirmed in irc by another tracker admin:

11:54 <@charles_> http://trac.transmissionbt.com/ticket/1218
11:55 < Mactus> We are using XBTT and that has not been an issue for us.
11:56 <@charles_> I see no indication on my end that it's true, and wanted a second opinion.  thanks. :)
11:56 < Mactus> sure...
11:56 < Mactus> Always glad to help
11:58 < Mactus> I have to say though, that the allowed versions are 1.2.2, 1.3.2 and as of this morning 1.3.3.

comment:3 Changed 13 years ago by federico62

Thank you for your answer. Could you please tell me what's changed between version 1.11 and 1.20 regarding the user-agent? Because this tracker is unable to cope with 1.20+ but has no problems with 1.11 and previous. I forgot to mention that all Transmission users on this tracker are stuck at 1.11 precisely for this reason (and the admins are not helping). Alternatively, could you please tell me how to activate curl debugging, so that I can trace the messages myself? Thank you for your assistance.

Note: See TracTickets for help on using tickets.