Opened 10 years ago

Closed 5 years ago

Last modified 4 years ago

#1220 closed Enhancement (fixed)

change file and folder names

Reported by: jkravny Owned by: jordan
Priority: Normal Milestone: 2.80
Component: Transmission Version: 1.33
Severity: Normal Keywords:
Cc: ian@…, ak@…, huskyr@…, llazy@…, redrat@…, alexrider, fortinmike@…, lazyboy993@…, Shu, web001@…, taem@…, samghost@…, ben@…, a_cr@…, dmalinovsky@…, aleksey.komlyk@…, stas@…, transmissionbt@…, blackst0ne.ru@…, nikoli@…

Description

in uTorrent, the top folder name in the torent is merely a suggestion and can be overridden, in transmission, this does not appear to be an option, is there reason?

there are many times after I download somthing...I'll move it to another location and try to clean up the folder name. I would love to repoint a torrent to the new location and top folder name

Attachments (5)

rename-top-dir.patch (18.6 KB) - added by ijuxda 8 years ago.
Patch to svn/trunk r11742
rename-torrent.patch (31.7 KB) - added by ijuxda 8 years ago.
Patch to svn/trunk r11758
rename-torrent_v2.patch (33.7 KB) - added by ijuxda 8 years ago.
Patch to svn/trunk r11889
rename-torrent_v3.patch (25.3 KB) - added by ijuxda 8 years ago.
Patch to svn/trunk r11895 changelog
tr-qt-rename.png (87.2 KB) - added by taem 6 years ago.

Download all attachments as: .zip

Change History (127)

comment:1 Changed 10 years ago by jkravny

  • Type changed from Bug to Enhancement

comment:2 Changed 10 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

The actual file downloaded has to have the same name, and adding this ability might cause confusion. The benefits don't outweigh the cost considering the small demand of such a feature.

comment:3 Changed 10 years ago by mactus

While the name of the payload itself has to remain the same, the top level folder containing the payload does not. This ticket was submitted after speaking with charles about it.

comment:4 Changed 10 years ago by livings124

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Fair enough.

comment:5 Changed 10 years ago by livings124

  • Priority changed from Normal to Low

comment:6 Changed 10 years ago by charles

#2018 has been closed as a duplicate of this ticket.

comment:7 Changed 10 years ago by charles

#2114 is related to this ticket.

comment:8 Changed 10 years ago by charles

##2135 has been closed as a duplicate of this ticket.

comment:9 Changed 9 years ago by naderr

  • Owner set to naderr
  • Priority changed from Low to High
  • Status changed from reopened to new

comment:10 Changed 9 years ago by naderr

  • Summary changed from top folder names being only "suggestions" to change top folder names
  • Version changed from 1.33 to 1.71

comment:11 Changed 9 years ago by naderr

  • Priority changed from High to Normal

comment:12 Changed 9 years ago by charles

  • Milestone changed from None Set to Sometime
  • Owner changed from naderr to charles
  • Status changed from new to assigned
  • Version changed from 1.71 to 1.33

comment:13 Changed 9 years ago by Grug

  • Cc ian@… added

I am very interested in seeing this functionality added to Transmission as this is currently the only reason I am still using Azureus (testing Transmission for downloads only). I am interested in working on this if no-one else is.

I currently have a separate torrents drive that I download onto. Once torrents are completed, I move them to their "correct" place in my directory structure and that usually includes renaming the base folder to something sane. I wish to continue seeding these torrents which requires this functionality to be added to Transmission for it to be feasible for me.

In addition to this, I frequently prefer to rationalise the filenames within torrents, especially those referenced by MythTV so the automatic filename matching for metadata downloading works. This means renaming the files within a torrent. This functionality is currently not included as part of this ticket, but has been mentioned in other tickets relating to this ticket (usually closed as wont-fix). I think this functionality is very much valid and therefore think it worthy of consideration at a later stage.

comment:14 Changed 9 years ago by HSerg

  • Cc HSerg@… added

comment:15 Changed 9 years ago by monk

  • Cc ak@… added

comment:16 Changed 9 years ago by huskyr

  • Cc huskyr@… added

comment:17 Changed 9 years ago by huskyr

Hi everyone, is anyone still busy with this ticket? It would really be a great addition, and it's virtually the only thing that i still miss from uTorrent. People tend to make up non-descriptive names for their torrent files, and then you're stuck with subdirectores like 'cool music' in your download folder, which you can't change if you still want to seed.

comment:18 Changed 9 years ago by charles

Nobody's working on this at the moment, but I agree it would be useful to have post-1.80

comment:19 Changed 9 years ago by lazy

  • Cc llazy@… added

The feature is very important for all seeding guys

comment:20 Changed 9 years ago by nicorac

My 2 cents for this feature.

I don't know if top-folder and torrent title are related, but I need title editing too: I often download torrents with long titles which doesn't show completely into console client I use (transmission-remote-cli.py).

comment:21 Changed 9 years ago by livings124

#2799 is similar to this, although seems to cover all files instead of the top.

comment:22 Changed 9 years ago by RedRat

  • Cc redrat@… added

I hope, this feature will be in Transmission some day, because this is the only thing which stops me of switching all my seed-boxes to Transmission.

comment:23 in reply to: ↑ description Changed 9 years ago by Fess

Hello, guys!

I support 20th comment of nicorac.

If I'm downloading some torrent-files with non-informative name (e.g. "(1-16)l1-02 by blah-blah-blah.torrent") I want to rename destination folder (or file) to my name, informative and correct. But I can't.

This problem does not allow me to seed all my downloaded torrents from another path (in Windows maked by uTorrent), because they were renamed by myself.

Please, provide us an ability to choose FULL path & name for downloads.

P.S. Sorry for my English! And I hope, this very important feature will be in Transmission in nearest future releases!!! :)

comment:24 follow-up: Changed 9 years ago by Paktas

This feature is needed very much. This is the only thing that keeps me migrating all torrent seeds from other clients.
I've got TBs of data being seeded and it would be impossible to have it all seeded from one folder. I (want) have it organized into right places.
I already see that individual torrents do have settings (selecting files for download and priorities), therefore this shouldn't be too hard to have each a setting for torrent data to be downloaded to specific folder.

comment:25 Changed 9 years ago by alexrider

  • Cc alexrider added

comment:26 Changed 9 years ago by Form

  • Cc fortinmike@… added

comment:27 Changed 9 years ago by acidjack

Please implement this feature. It will be very useful for many users of transmission.

comment:28 in reply to: ↑ 24 Changed 9 years ago by mike3050

spam deleted

Last edited 9 years ago by livings124 (previous) (diff)

comment:29 Changed 8 years ago by jcabrera

  • Cc jcabrera.moreno@… added

As a new user of Transmission, this was the first thing I noticed that was missing. I like to have my folders organized with the proper name and the same format between folders, I don't like the folder to be separated by periods or with the signature of the uploader. For instance, uTorrent on Windows allows you to change it. I think it is an important feature to have. Hope it is addressed soon. Kudos to the Transmission dev team!

Last edited 8 years ago by jcabrera (previous) (diff)

comment:30 Changed 8 years ago by username?

As I see it the easiest way to describe it is simply to rename the torrent (ie the name in the metadata of the torrent)? Because the "top folder"-name IS the torrent name. That shouldn't be too hard to do.

Well, maybe its not good practice to edit the actual .torrent file, but that would certainly be an easy thing to do. Another option might be to have an separate "alternative" name in the resume-file and keep the original torrent file (but i have a feeling that will make for some greater changes in the source code).

comment:31 Changed 8 years ago by prophet36

I'd like this feature too.

comment:32 Changed 8 years ago by starmoon

need it very much.

comment:33 Changed 8 years ago by lazyboy993

  • Cc lazyboy993@… added

Waiting for this also.

comment:34 Changed 8 years ago by charles

  • Milestone changed from Sometime to 2.20

comment:35 Changed 8 years ago by spirtbrat

Actually the filenames and the hierarchy is only _suggested_. The crucial thing is the hash value of the files.

If someone intent to keep any file from a torrent, he/she is (most probably) also willing to seed it. The computers are very personal and people like to organize files in certain way. Forcing hierarchy and obscure filenames makes sharing files and keeping the system organized very difficult to combine. File sharing can also be done without disturbing the personal comfort.

The only thing needed is, for example, a simple reference file (maybe JSON) which maps files with hash values from torrents. Something like

<hash value> <path-to-filename>

for every remapped file.

This is a very cool feature and will create many long-time seeders. I (and not only me), for example, have many things I'd like to keep, sometimes for years. A simple remapping feature will allow me to seed them indefinitely.

If I knew how to code, I would implement it. I hope someone consider it in the near future.

comment:36 Changed 8 years ago by spirtbrat

  • Cc bustervill@… added

comment:37 Changed 8 years ago by Shu

  • Cc Shu added

comment:38 Changed 8 years ago by livings124

#3679 overlaps with this.

comment:39 follow-up: Changed 8 years ago by jordan

  • Milestone changed from 2.20 to Sometime

This feature is going to happen, but we're getting close to the 2.20 freeze and this isn't a good ticket to do as a last-minute change.

comment:40 in reply to: ↑ 39 Changed 8 years ago by RedRat

Replying to jordan:

This feature is going to happen, but we're getting close to the 2.20 freeze and this isn't a good ticket to do as a last-minute change.

:-(((

Well, we are believers! We will keep waiting...

comment:41 Changed 8 years ago by zeroj

  • Cc web001@… added

Changed 8 years ago by ijuxda

Patch to svn/trunk r11742

comment:42 follow-up: Changed 8 years ago by ijuxda

Here's a preliminary implementation with rpc, remote and gtk support.

The approach is to modify the directory prefix in file->name (i.e. torrent->info.files[i].name for each i) and use rename(2) to move the directory. In order for the files to be found again on resume, the name field is saved for each file in the resume data. This may not be the cleanest or most efficient way to implement the feature; I'm open to better ideas.

Testing appreciated.

comment:43 in reply to: ↑ 42 ; follow-up: Changed 8 years ago by taem

Replying to ijuxda:

Testing appreciated.

Tested daemon remote and gtk clients. Works pretty well. But one thing. In torrents list, torrent with the renamed top dir have an old name. For example, "My Torrent" renamed to "MyTorrent?", but client still shows it with old name "My Torrent". IMHO, it is confusing.

comment:44 Changed 8 years ago by taem

  • Cc taem@… added

comment:45 Changed 8 years ago by taem

I'm using Qt client. It's can't find data for torrents with the renamed top dir.

Changed 8 years ago by ijuxda

Patch to svn/trunk r11758

comment:46 in reply to: ↑ 43 ; follow-ups: Changed 8 years ago by ijuxda

Replying to taem:

Tested daemon remote and gtk clients. Works pretty well. But one thing. In torrents list, torrent with the renamed top dir have an old name. For example, "My Torrent" renamed to "MyTorrent?", but client still shows it with old name "My Torrent". IMHO, it is confusing.

I agree, so I reworked the patch to be a more general purpose torrent renaming feature (rename-torrent.patch).

Unfortunately this involved replacing direct accesses of torrent->info.name with tr_torrentName(), which somewhat increases the amount of changes in the patch and makes it necessary to update old code in the qt and macosx codebases.

Be sure to report here if during testing you find the original torrent names showing up in places where they do not belong (at least during rpc, remote and gtk tests).

I'm using Qt client. It's can't find data for torrents with the renamed top dir.

Yes this is somewhat strange and I'm not sure what exactly causes it. I don't use or maintain the qt client myself, so while I may at some point in the future have a look at it, it will not be before the implementation of this feature is finalized and tested for rpc/remote/gtk.

Last edited 8 years ago by ijuxda (previous) (diff)

comment:47 in reply to: ↑ 46 Changed 8 years ago by taem

Replying to ijuxda:

Be sure to report here if during testing you find the original torrent names showing up in places where they do not belong (at least during rpc, remote and gtk tests).

Everything is ok.

comment:48 in reply to: ↑ 46 Changed 8 years ago by taem

Replying to ijuxda:

I'm using Qt client. It's can't find data for torrents with the renamed top dir.

Yes this is somewhat strange and I'm not sure what exactly causes it. I don't use or maintain the qt client myself, so while I may at some point in the future have a look at it, it will not be before the implementation of this feature is finalized and tested for rpc/remote/gtk.

Qt client is OK too.

Changed 8 years ago by ijuxda

Patch to svn/trunk r11889

comment:49 Changed 8 years ago by ijuxda

Version 2 has better handling of incomplete metadata (i.e. magnet links) and allows torrents to be renamed without having to restart them.

comment:50 Changed 8 years ago by jcabrera

  • Cc jcabrera.moreno@… removed

Changed 8 years ago by ijuxda

Patch to svn/trunk r11895 changelog

comment:51 Changed 8 years ago by killazys

hi, when applying your patch on fedora 14 x64, i get multiple errors, including

|diff --git a/daemon/remote.c b/daemon/remote.c
|index 9c56c49..b5a223d 100644
|--- a/daemon/remote.c
|+++ b/daemon/remote.c
|diff --git a/gtk/actions.c b/gtk/actions.c
|index 2eb817c..ac975cc 100644
|--- a/gtk/actions.c
|+++ b/gtk/actions.c

among others. Any ideas what's causing this? I have both transmission and qtransmission installed, v2.11

comment:52 Changed 8 years ago by x190

Your version is too old. You need to patch to r11895 or higher from svn/trunk.

comment:53 Changed 8 years ago by metaclam

Glad to see this is going to happen! It will be very useful for XBMC to recognize movies in absurdly stupid folder names. :)

comment:54 Changed 8 years ago by sambrightman

  • Cc samghost@… added

comment:55 Changed 8 years ago by bena

  • Cc ben@… added

comment:56 Changed 8 years ago by Bredkov

I hope it will be sometime avaible (rename of file). Still can't find solution for XBMX to auto recognize movies in wrong names (translit) :(

comment:57 Changed 8 years ago by jordan

  • Milestone changed from Sometime to 2.40

comment:58 Changed 8 years ago by Bredkov

Good news ... i hope it will be so ...

comment:59 Changed 8 years ago by mark_ablov

Sometime ago i wrote article about patching it - http://habrahabr.ru/blogs/p2p/119274/ (in Russian only). It based on ijuxda's patch, but has some changes. For example, i do not patch tr_torrentName(), because it spoil magnet-link generation and several log messages.

And i've add one more feature - "displayName", it resume-state-based field, that just contains simple string and we can access it by rpc getter/setter. It allow's to modify rpc-clients to display names, that i want, but not names that are kept in metadata.

comment:60 Changed 8 years ago by alcr

  • Cc a_cr@… added

comment:61 follow-up: Changed 8 years ago by alcr

Allow renaming only top folder is not enough. I should be able to rename any file in torrent.

comment:62 Changed 7 years ago by dmalinovsky

  • Cc dmalinovsky@… added

comment:63 in reply to: ↑ 61 Changed 7 years ago by dukdukgoos

Replying to alcr:

Allow renaming only top folder is not enough. I should be able to rename any file in torrent.

I strongly agree with this statement. Hopefully the patch being considered isn't only for folders but also files within the torrent as well. e.g. original torrent contains clonezilla-live-1.2.9-19-i486.iso file (not in a folder) which I then rename to clonezilla.iso and continue to seed. utorrent does this this well, and it's a very important feature for long-term seeders.

comment:64 Changed 7 years ago by jordan

  • Milestone changed from 2.40 to Sometime

I probably shouldn't milestone these things until I have reviewed code ready. :/

Queuing will be the New Big for 2.40.

comment:65 Changed 7 years ago by alex000

  • Cc aleksey.komlyk@… added

comment:66 Changed 7 years ago by lazybones

deluge supports both folder and content file renaming without breaking seeding... It is incredibly useful as others have said for long term seeding but maintaining local file order and naming.

comment:67 Changed 7 years ago by Stark

  • Cc stas@… added

comment:68 Changed 7 years ago by mrpitchfork

It's a bit frustrating to see that this has been desired for four years and ignored, when the next release is set to implement a feature that's purely a convenience and not a major functionality. We can already pause torrents and do queuing manually, but there's no real way to sort files the way we want to and also seed torrents. Can we please please pretty please pretty pretty please have this as the next big thing? It would seriously thrill/chill/fulfill me.

comment:69 Changed 7 years ago by lazybones

I actually moved to deluge JUST for the file rename features. When used with Flexget you can actually get automatic file name cleanup AND properly seed torrents.

Seeing larger torrents can take some time, duplicating the file content or maintaining the original naming till seeding is complete is not really practical in many cases.

I really thing that the built in ability to rename and relocate the content files would really be good for the health of some swarms.

I am not entirely thrilled with deluge for a few reasons and would switch back to Transmission in a heartbeat if this was correctly supported but at the moment file renaming is a killed feature to me.

comment:70 Changed 7 years ago by RedRat

We dream of this important feature for 4 years!

comment:71 Changed 7 years ago by Gigi

Transmission is an awesome client, but unfortunately I can't use it since my files are all over the place. Please implement this!!

comment:72 Changed 7 years ago by phils

  • Cc transmissionbt@… added

comment:73 Changed 7 years ago by blackst0ne

Any news here?

comment:74 Changed 7 years ago by blackst0ne

  • Cc blackst0ne.ru@… added

comment:75 Changed 7 years ago by MaximumFish

This single feature would make me switch from rTorrent in a flash. I admit that I'm no coder, but it must be pretty trivial to implement, surely?

rTorrent/ruTorrent does it a little differently by having the option, "Don't add torrent's name to path", but it achieves the same end result. You just choose the exact save location and check the box rather than choosing one directory up and then renaming the torrent's top level.

You'd make a lot of people very happy if you added this! :)

comment:76 Changed 6 years ago by marspeople

  • Cc marspeoplester@… added

comment:77 Changed 6 years ago by diogyk

  • Priority changed from Normal to Highest
  • Severity changed from Normal to Critical
  • Version changed from 1.33 to 2.61

I am also thinking of switching back to deluge just because of this option, it's critical for me to be able to rename file and folderlist, reason for that is that I want my PC files and folders to be organised. I like to name them neatly understandably. I hope this feature will be added soon!

comment:78 Changed 6 years ago by livings124

  • Priority changed from Highest to Normal
  • Severity changed from Critical to Normal
  • Version changed from 2.61 to 1.33

comment:79 Changed 6 years ago by RockBomber

I vote for this feature! It's very important for many users. Please, implement it.

comment:80 Changed 6 years ago by Atsekabe

I would gladly fund (using PayPal?, for instance) this request to see it implemented. Many people, myself included, have a folder where we download stuff that later on we rename and categorize.

comment:81 Changed 6 years ago by livings124

If you enjoy using our application, then please feel free to donate (http://www.transmissionbt.com/donate.php). We don't do bounties.

comment:82 Changed 6 years ago by slaute

I add up my voice for this feature (including not only folder rename, but any file of the torrent). I always stop seeding torrents just because their name does not fit my organization scheme.

So, PLEASE PLEASE PLEASE consider it an important enhacement. I think this is a good feature for Transmission users, but also for the health of the swarm.

Thanks, and count on my donation.

comment:83 Changed 6 years ago by Nick222

When torrent-file made under Windows - and I try to load it under Linux (Xubuntu 12.10-64, codepage UTF-8, FS ext4), releaze cannot start, because of file name is too long. I must rename file to make it shortly (manually or automatic) - bit I cannot do it by Transmission :(

comment:84 Changed 6 years ago by jay15

Please add me to the list of people who would really appreciate this feature. I have accumulated many torrents over the years and have always had to stop seeding (after a time) to rename and reorganize files. I run a Linux seedbox day and night. This feature would enable me to re-seed a great deal of old torrents. I would also be willing to pay for this feature, assuming there is a special place to donate to this specific cause. Thank you very much for this excellent piece of software.

comment:85 Changed 6 years ago by Pierobon

I desperately need this too. At least add this feature to the torrent top level folder for now, please!

comment:86 Changed 6 years ago by spirtbrat

  • Cc bustervill@… removed

comment:87 Changed 6 years ago by jordan

  • Milestone changed from Sometime to 2.80
  • Owner changed from charles to jordan
  • Status changed from assigned to new

comment:88 Changed 6 years ago by jordan

r13807: added support for this in libtransmission's C and RPC APIs.

r13808: add file-renaming to the GTK+ GUI

comment:89 Changed 6 years ago by RedRat

Hallelujah! At last! :-)

comment:90 Changed 6 years ago by Pierobon

Will this be available inside the daemon too?

comment:91 Changed 6 years ago by jordan

r13809: tweak the API documentation in

r13810: add file-renaming to the Qt client

Pierobon: it's available via the RPC interface, if that's what you mean.

comment:92 Changed 6 years ago by slaute

I see changes to different UIs, is the Mac UI planned to be modified for 2.80 as well? Also, the feature that's being implemented what will allow exactly? The change of name of the top folder? Any file inside?

Thanks a lot for your work.

comment:93 Changed 6 years ago by jordan

The changes I made to libtransmission allow any folder or file in the torrent to be changed.

I don't know how it will behave in the Mac Client; that's livings124's decision.

comment:94 Changed 6 years ago by livings124

  • Summary changed from change top folder names to change file and folder names

comment:95 Changed 6 years ago by livings124

Mac: r13828

comment:96 Changed 6 years ago by jordan

r13829: when the root file/folder is changed, update tr_info.name too

comment:97 Changed 6 years ago by taem

Hi,

There is some unconventional behavior when renaming torrent in Qt client. Steps to reproduce:

  1. double click to rename file
  2. editbox will be blank
  3. discard editing by clicking somewhere outside of the editbox
  4. program will show error (screenshot attached)

I guess, step 3 should act like ESC key. And I think in step 2, editbox should be filled with the filename as expected.

Thanks.

Changed 6 years ago by taem

comment:98 Changed 6 years ago by jordan

r13849: fix Qt renaming issue reported by taem in https://trac.transmissionbt.com/ticket/1220#comment:97

comment:99 Changed 6 years ago by taem

Rename test is failing for r13892.

make  check-TESTS
make[3]: Entering directory `/home/taem/src/transmission/transmission/libtransmission'
PASS: bitfield-test
PASS: blocklist-test
PASS: clients-test
PASS: history-test
PASS: json-test
PASS: magnet-test
PASS: metainfo-test
PASS: move-test
PASS: peer-msgs-test
PASS: quark-test
FAIL rename-test.c:237
FAIL: rename-test
PASS: rpc-test
PASS: test-peer-id
PASS: utils-test
PASS: variant-test
=========================================================
1 of 15 tests failed
Please report to http://trac.transmissionbt.com/newticket
=========================================================

comment:100 follow-up: Changed 6 years ago by jordan

taem, this should be fixed now. Please add a new comment if you're still seeing this problem.

comment:101 in reply to: ↑ 100 Changed 6 years ago by taem

Replying to jordan:

taem, this should be fixed now. Please add a new comment if you're still seeing this problem.

Everything is ok.

comment:102 Changed 6 years ago by jordan

  • Resolution set to fixed
  • Status changed from new to closed

comment:103 Changed 6 years ago by HSerg

  • Cc HSerg@… removed

comment:104 follow-up: Changed 6 years ago by telecore

Erm.... why this one is closed if the renaming feature is implemented only in the GTK+ GUI?

comment:105 in reply to: ↑ 104 Changed 6 years ago by x190

Replying to telecore:

Erm.... why this one is closed if the renaming feature is implemented only in the GTK+ GUI?

https://trac.transmissionbt.com/ticket/1220#comment:91

comment:106 Changed 6 years ago by Nikoli

  • Cc nikoli@… added

comment:107 Changed 6 years ago by MaximumFish

I'm a little confused and hoping someone can shed some light on the current situation. This bug was marked as fixed and closed with a milestone of 2.80, right? Meaning as of version 2.80 the functionality will be included in the stable release on the main website?

Only the bug was closed 3 months ago and the version on the website is still 2.77. Is there actually a timeframe for the 2.80 release or have I missed the point somewhere? I'm using Transmission on a Synology NAS, the package for which is built around the current stable release, so it's not like I can simply download a nightly build to get this functionality.

Appreciate any insight into this. Thanks.

comment:108 Changed 6 years ago by livings124

This functionality will be in 2.80 when it is released. No release date yet, but nightlies are available and it can be built from source.

comment:109 follow-up: Changed 6 years ago by Rapper_skull

Please add torrent rename function when adding a torrent too.

comment:110 in reply to: ↑ 109 Changed 6 years ago by RedRat

Replying to Rapper_skull:

Please add torrent rename function when adding a torrent too.

Open a new ticket. This one closed.

comment:111 Changed 5 years ago by jsahlen

Is this available in transmission-remote in trunk? Or what's the best way to use it without a desktop GUI?

comment:112 Changed 5 years ago by Nick222

  • Resolution fixed deleted
  • Status changed from closed to reopened

Transmission updated to 2.80.

Problems:

1) If file became downloading and then stoped (because file name too long) - I can change file name, but I cannot start downloading again, because Transmission cannot find already downloaded parts(I think - it do not renamed already downloaded file or temporary file).

2) If file do not downloaded yet at all and I rename it - Transmission say "Cannot save resume file" (I think that resume file do not renamed and name of resume file is the same as start name of downloading file).

OS: Xubuntu 13.04 FS: Ext4

comment:113 Changed 5 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

Please reopen as a new bug report.

comment:114 Changed 5 years ago by Sadomodo

Am I dumb, or is there no such option available in the webUI ?

comment:115 Changed 5 years ago by jordan

Not yet. Patches are welcomed though :)

comment:116 Changed 5 years ago by zilexa

Any news when this feature will be added to the webUI? Being able to rename a folder == more people will keep seeding their files. Since you cannot organize your files without breaking the link with the torrent, you cannot seed.

I am not a developer otherwise I would dive in this project myself.

Please do give us a notification if and when this has been planned.

comment:117 Changed 5 years ago by jordan

This is something that should go in the web client, but there's not any work currently scheduled to add it.

comment:118 Changed 5 years ago by brooc

Can this be added to transmission-daemon and of course to the web-UI? This is really important...

comment:119 Changed 5 years ago by datakey

Use this: https://code.google.com/p/transmisson-remote-gui/ instead of WebUI. It is added to -daemon already, but not to WebUI.

comment:120 follow-up: Changed 4 years ago by novelkeny

uTorrent supports not only renaming the files and folders, but actually relocating files to different folder structures (for example I can move subtitles files located in the subtitle folder to its parent folder). The users might not want to keep the original folder structure in the seed. Can Transmission implement something like this?

Also, webUI support will be nice.

comment:121 in reply to: ↑ 120 Changed 4 years ago by mike.dld

Replying to novelkeny:

uTorrent supports not only renaming the files and folders, but actually relocating files to different folder structures (for example I can move subtitles files located in the subtitle folder to its parent folder). The users might not want to keep the original folder structure in the seed. Can Transmission implement something like this?

See #5347.

comment:122 Changed 4 years ago by marspeople

  • Cc marspeoplester@… removed
Note: See TracTickets for help on using tickets.