Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#1249 closed Bug (fixed)

Build problems on BSD

Reported by: geirha Owned by: charles
Priority: Normal Milestone: 1.34
Component: Transmission Version: 1.33
Severity: Normal Keywords:
Cc:

Description

There seems to be a problem with the build system when building on openbsd: http://www.smacked.org/blog/transmission-openbsd/

A user on #transmission reported the same two problems with the 1.33 sources on freebsd. I don't have bsd myself, just making sure it gets reported so someone can look into it :)

Change History (9)

comment:1 Changed 13 years ago by mezz

The first part related with OpenSSL, it's a known issue and developers will not make any change. As for the second part, I can't reproduce it on FreeBSD and we have Transmission in our ports tree. Also, I have not get any of build failure report from the users and even from the three different tinderboxes.

I have taken a look this blog and I have noticed one thing... It's 'make'. Have you tried to use gmake instead of make?

comment:2 Changed 13 years ago by charles

The OpenSSL/BSD issue is a duplicate of ticket #450.

Mezz: if you want to submit a patch to configure.ac so that configure looks for OpenSSL with pkg-config first, but then falls back to whatever tests BSD requires, I'd accept that patch.

Also I'd like to hear if there's a counterargument to my last comment in ticket #450. Surely Transmission isn't the only package affected by this?

comment:3 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40
  • Resolution set to fixed
  • Status changed from new to closed

Part 1/2: duplicate of #450.

Part 2/2: fixed in r6694

comment:4 Changed 13 years ago by charles

  • Keywords backport-candidate added

comment:5 Changed 13 years ago by charles

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by charles

  • Owner set to charles
  • Status changed from reopened to new

comment:7 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from new to closed

comment:8 Changed 13 years ago by charles

backported to 1.3x branch in r6756

comment:9 Changed 13 years ago by charles

  • Keywords backport-candidate removed
  • Milestone changed from 1.40 to 1.34
Note: See TracTickets for help on using tickets.