Opened 12 years ago

Closed 12 years ago

#1253 closed Bug (worksforme)

Priorities are not always reestablished after internet loss

Reported by: dwt Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.33
Severity: Normal Keywords:
Cc:

Description

after Transmission looses it's connectivity, sometimes the priorities are not set again on the core. They still are reflected in the GUI, however they have no influence on what is actually downloaded.

Change History (19)

comment:1 Changed 12 years ago by livings124

  • Component changed from Mac Client to libtransmission
  • Owner changed from livings124 to charles

If this is an issue, it's a libtransmission issue.

comment:2 Changed 12 years ago by livings124

What do you mean they are not set again on the core? Is this repeatable for multiple torrents? Are you sure it's just not some files in the transfer having better availability or the luck of the draw?

comment:3 Changed 12 years ago by dwt

Well, I means that when I don't reset the priorities after Transmission completely looses connectivity those files with priorities don't get downloaded at all (which is an aproximation).

My test-case is a .torrent with a size of 50 Gigabyte, from which I download the files pretty much in order. When prioritized one file (300 mb) gets downloaded overnight - or at least it gets downloaded almost.

If I forget to reset the priorities (I'm not completely sure what the minimal steps to reproduce this would be), Transmission downloads those files just as much as it does all the rest - the Priorities are completely forgotten.

I will monitor this closely and try to provide more reducton advice. But this is what I have right now.

comment:4 Changed 12 years ago by dwt

Oh, with minimal I mean - I just have adium running and use my laptop at various locations - when changing locations network settings completely change and thus Transmission has to start over when I re-attach to a network somewhere else.

Which of these changes in network settings and perimeter it is exactly that causes this I'm not sure - but it has to be the changing of networks.

comment:5 Changed 12 years ago by charles

  • Component changed from libtransmission to Transmission
  • Owner charles deleted

The more I read about this ticket, the less I understand what's being said.

So you're saying you have a torrent running in Transmission on your computer, and you (for example) set file #1 to be a high priority. Then you exit Transmission, move to a different network location, restart transmission, open up the Inspector, look at the file priorities, and file #1 is no longer listed as being a high priority in the Inspector. Is that what you're seeing, or some other behavior?

comment:6 Changed 12 years ago by dwt

I think I've got it nailed now.

To reproduce:

  • Open a torrent (large with many files preffered)
  • Set some files to have high priority
  • Watch them get downloaded much faster than the other files
  • Restart Transmission
  • Open up the Inspector to verify that those files still are shown to have high priority
  • Watch the prioritized files get downloaded no faster than all the other files.

I hope this is clear enough to reproduce it on your path.

I am sure I have also seen this when not restarting, but just changing network locations - but this is how I was able to reproduce it tonight.

comment:7 Changed 12 years ago by livings124

Are you sure this isn't the luck of the draw? This is consistently repeatable for more than one torrent? I just can't think of how this could happen, besides the fact that priorities, in their very nature, aren't guaranteed to be followed 100%.

comment:8 Changed 12 years ago by dwt

Yes, this is definitely repeatable and to not be the luck of the draw.

However I haven't had the time to verify this with multiple torrents (usually I don't really download a lot with torrents).

I guess however that you can replicate this very easily in a dedicated test-grid where you have everything under control.

comment:10 Changed 12 years ago by livings124

On 1.40 (or a nightly) is this still an issue?

comment:11 Changed 12 years ago by dwt

Hard to say, as I don't usually have [big] downloads. I'l watch out for it though.

comment:12 Changed 12 years ago by livings124

If it's not an issue please close this. You're the only one to report it.

comment:13 Changed 12 years ago by dwt

  • Resolution set to fixed
  • Status changed from new to closed

Well it still seems to be an issue from my tests.

To verify:

  • Download a Torrent with many files
  • Turn down priority on all of them
  • Turn up the priority on one file
  • Quit Transmission
  • Restart it
  • Wait and see if that file gets a preferential treatment and is downloaded first.

comment:14 Changed 12 years ago by dwt

  • Resolution fixed deleted
  • Status changed from closed to reopened

Damn, I'l never get used to using web-guis. Sorry for the close, that was a mis-click.

comment:15 Changed 12 years ago by dwt

I should add that I tried this on 1.40

comment:16 Changed 12 years ago by livings124

Is this still an issue with the latest nightly/1.41b2?

comment:17 Changed 12 years ago by dwt

I'l try to look into it next week!

comment:18 Changed 12 years ago by livings124

dwt: ping

comment:19 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

Without any more feedback or other users reporting this, I'm going to assume either it was a non-issue or fixed in r7242.

Note: See TracTickets for help on using tickets.