Opened 13 years ago

Closed 13 years ago

#1260 closed Bug (worksforme)

Port won't open in Mac client

Reported by: jayeff Owned by:
Priority: High Milestone: None Set
Component: Transmission Version: 1.33
Severity: Critical Keywords: port forwarding
Cc: jfarrelly@…

Description

In the most recent builds of Transmission, I've taken all the necessary steps to try to open ports, but no matter what I do, the program says the port is closed and download and upload speeds are horrible.

I know the port's open, because http://www.canyouseeme.org/ can see the port just fine.

I'm using an up-to-date version of Leopard, and an Actiontec router, but this problem has also occured for me on a Hackintosh computer running Leopard with a Netgear router, so I doubt the problem is isolated to my setup.

I've read the forums, to no avail, because although this problem seems to be somewhat widespread amongst posters, there are no solutions. This is the first time I've reported a bug, so I'm not sure what else I should include.

Change History (13)

comment:1 Changed 13 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

Portforwarding is handled by miniupmnp (http://miniupnp.tuxfamily.org/). Any problems with it should be reported upstream to them.

comment:2 Changed 13 years ago by livings124

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:3 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

comment:4 Changed 13 years ago by jayeff

  • Resolution worksforme deleted
  • Status changed from closed to reopened

miniupmnp (http://miniupnp.tuxfamily.org/), on its front page, says:

July 14th 2008 : Sorry, the miniupnpc-1.1 does not install properly all .h. I was also informed that it doesn't compile without changes on Mac OS X.

There are also several people in the Transmission forums facing the very same problem. so 'resolution set to worksforme' seems like a cop-out. I understand that I'd have to go somewhere else to ask about port forwarding, but please don't insult me by telling me that even though I went out of my way to report a problem, you don't give a damn (which is basically what I gather when you close a ticket with worksforme )

comment:5 Changed 13 years ago by charles

I don't understand this ticket. If http://www.canyouseeme.org/ says the port is open, what is the problem?

comment:6 Changed 13 years ago by livings124

If port forwarding doesn't work, the place to debug it is the forums (I assume you read the built in help and the wiki already). If you can determine it is definitely not your setup, the the miniupnp developer is the one to go to.

comment:7 Changed 13 years ago by jayeff

@charles, even though canyouseeme.org says it's open, Transmission says it's closed when I try to set the port. Also, the speeds I'm getting are similar to the speeds I get when I do have to download with a closed port.

@livings124, I didn't post on the forums, because the problem was already brought up. In one instance, the advice was 'look somewhere else' ( http://forum.transmissionbt.com/viewtopic.php?f=4&t=5852 ), and a few were never answered (http://forum.transmissionbt.com/viewtopic.php?f=4&t=5849 ... http://forum.transmissionbt.com/viewtopic.php?f=4&t=5673).

The only sort of helpful post in the forum is this one http://forum.transmissionbt.com/viewtopic.php?f=4&t=5743 , where Transmission Developer Charles Kerr says that port forwarding code within T hasn't changed in a long long time, so he doesn't know what could be causing this behavior.

So yes, i've been through all the steps, and I've tried to report a bug, because I honestly like the software. It's not my setup (if it was, canyouseeme.org would have failed), and the forums, help, and the wiki don't cover this specific problem.

comment:8 Changed 13 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

So far all we know is that:

  1. Transmission says your port is closed and speeds match when downloading with a slow port
  2. You do not want to attempt to get support on the forums
  3. You do not want to contact the maintainer of the port forwarding code
  4. Port forwarding in itself is a tricky thing to support, because of the many different setups, with many (most) of the problems resulting from problems with the setup

Since port forwarding does work for many users and we haven't modified the code in a long while (so it's most likely not something breaking recently that wouldn't have been caught), I'm going to have to close this.

comment:9 Changed 13 years ago by livings124

In one I meant closed port (trac really needs an edit button)

comment:10 Changed 13 years ago by jayeff

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Listen man, and please don't treat me like a n00b or condescendingly talk down to me like you've been doing. I'm trying to help make this software better.

All I wanted to do is bring to your attention that there's a bug in Transmission that messes with port forwarding. It's not my setup, and it's not only me.

"Since port forwarding does work for many users" .... but it doesn't work for many others! There's a bug in Transmission.

It's been brought up in the forums by several different people on several different occasions. I consulted the forums, that's the first thing I did. Why would I make another useless post that would clog up the forum, where there are already many threads there left unresolved? I looked for the support on the forums, it's not there.

And, since this is a place to post bugs for the program Transmission, and the program itself, Transmission , isn't working properly, I'm reporting the Transmission bug.

"4. Port forwarding in itself is a tricky thing to support, because of the many different setups, with many (most) of the problems resulting from problems with the setup " ... stop trying to insult me. My setup worked fine before, and I updated Transmission, and it stoped working. I went through all the troubleshooting. It's not me. Stop making excuses.

Now, in case for any reason I'm not being clear: I've done all the prerequisite reading and troubleshooting. I've seen this issue unresolved in the forums. There are no answers in the built in help or wiki for this specific problem.

There's a bug in Transmission, where for some users (not just me) it won't show a port is open (and won't transfer at open speeds) when by all accounts it should. This problem is recent, as in 1.22 it worked fine, but not anymore.

This doesn't affect everyone, but it affects enough users that there are already multiple threads in the forums left unresolved. It is a problem.

I've tried to help make a piece of software I use better, but livings124, thanks for treating me like shit when I report a problem. Can I request someone else other than livings124 to help me out? Cause closing a ticket with 'worksforme' makes me just want to say fuck it, stop trying to help, and find another client.

comment:11 Changed 13 years ago by jah

  • Resolution set to worksforme
  • Status changed from reopened to closed

@jayeff, you won't get anywhere by being rude.

Both developers (charles and livings124) have stated that they don't believe this is a bug. Given that they actually develop the application, I'm pretty sure they would be well qualified to make this judgement.

T has over 500k users, the majority of whom will be doing some sort of port forwarding. If you consider the number of forum threads as a % of the total user base, it is clearly a very very small number of users who are having issues, and 99% of the time it comes about because they haven't used the numerous resources available to troubleshoot their problem.

comment:12 Changed 13 years ago by jayeff

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I wasn't being rude, all I was trying to do was report what I perceived was a bug in the recent builds of the program. When I did, however, my ticket was tossed aside without any explanation, and I was told to do what I've already done. Rudeness is closing a ticket with just 'resolution set to worksforme' without doing any sort of follow up.

But, since you think charles stated that he doesn't 'believe this is a bug', I'm pretty sure you just glanced at this ticket and didn't actually read it. (If you can find where charles states he doesn't believe this is a bug, i'll be very impressed).

And livings124 didn't give me a straight answer. He told me that a) a third party maintains the code for the port forwarding, and then b) they haven't changed the port forwarding code. So, which is it? He obviously didn't develop the port forwarding stuff (miniupmnp http://miniupnp.tuxfamily.org/ did, so obviously it's not a given that he developed that part of the application. Moreover, I didn't know that their developers. I just assumed they were moderators. I guess that's my bad, but an explanation, instead of just rudely closing a ticket with a 'works for me' would have cleared up that assumption. (or trac having a signature option).

And I realize a lot of the problems on the forums are n00bs who don't troubleshoot their own problems. But, I've linked to a few threads with the exact same problem as me, after troubleshooting, with no resolution. There is a problem, even if it doesn't affect everyone.

Finally, calling me rude does nothing to explain why, after going through the forums, the wiki, the built in help, and making sure everything is correct (it is), that Transmission still won't forward a port. By all means, it should, but there's something in the new builds that doesn't work for some users.

(PS, I'm reopening the ticket to make sure someone reads this, I realize now that pointing out bugs in the place to point out bugs is useless, because although it's affecting more than one person, no one here actually believes a user who took the time to report a bug in the first place).

comment:13 Changed 13 years ago by jah

  • Resolution set to worksforme
  • Status changed from reopened to closed

@jayeff, even if the behaviour you are experiencing is a bug, your 'bug report' isn't useful for a couple of reasons.

Firstly, you have posted no debug log or other information which might be useful for the developers. Obtaining and posting the debug log is a troubleshooting step in the built in help which i'm assuming you have read?

Secondly, as livings pointed out, T uses another library for its port mapping code, called 'miniupnp'. Thus, even if it is a bug, it is not necessarily something the developers here can fix. As he suggested to you, you need to contact the developers of miniupnp, either on their forums or by posting a ticket on their system.

Thirdly, you have stated you are unsure of the procedure of what to include in bug reports etc. For this reason, you should make a new topic on the forums and ask for advice. Tickets on the trac system are not threads for general discussion, but rather to clarify specifics of the bug/enhancement.

Finally, having read your problem, and given my extensive experience with T, IMO it is not a bug, and for this reason I am closing it again until you can provide further evidence (on the forums). Regards.

Note: See TracTickets for help on using tickets.