Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#1264 closed Bug (fixed)

inconsistent speed reporting

Reported by: jah Owned by: charles
Priority: Lowest Milestone: 1.40
Component: libtransmission Version: 1.33
Severity: Trivial Keywords:
Cc:

Description

In the OS X version, total speed doesn't exactly correlate with group speed due to 'differences in rounding'. Apparently the solution is to incorporate groups into libT directly.

cheers :)

Change History (17)

comment:1 Changed 13 years ago by livings124

  • Priority changed from Normal to Lowest
  • Severity changed from Normal to Trivial

comment:2 Changed 13 years ago by livings124

They don't correspond because groups are adding the individual rates (in the gui code), while total is based off of a single value grabbed from libtransmission.

comment:3 Changed 13 years ago by livings124

  • Component changed from Transmission to libtransmission
  • Owner set to charles

comment:4 Changed 13 years ago by charles

jah: do the speeds sync up any better now, after the speed limit rewrite?

comment:5 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

jah: please reopen this ticket when you answer the question in comment #4

comment:6 Changed 13 years ago by jah

  • Resolution invalid deleted
  • Status changed from closed to reopened

charles: no, i'm afraid its even worse now. This is using r6819.

comment:7 Changed 13 years ago by charles

  • Component changed from libtransmission to Mac Client

comment:8 Changed 13 years ago by livings124

  • Component changed from Mac Client to libtransmission

comment:9 Changed 13 years ago by charles

livings124: I am not putting group support in libtransmission; it doesn't make any sense at all.

If you want this to be a libtransmission ticket, please change the topic to something like "speed measurements are inconsistent" and explain which libtransmission API calls are being made whose results are inconsistent with one another. Otherwise this ticket should be closed.

comment:10 Changed 13 years ago by charles

  • Component changed from libtransmission to Mac Client

comment:11 Changed 13 years ago by livings124

This isn't a mac ticket - i just add together the speeds of each torrent in a group and display. This is an issue where adding all the values of torrent speeds together does not equal the total speeds given in libT. Of course I don't expect group support in libT - I never did.

comment:12 Changed 13 years ago by livings124

  • Component changed from Mac Client to libtransmission

comment:13 Changed 13 years ago by charles

  • Summary changed from group support in libT to inconsistent speed reporting

livings124, jah: how about now, as of r6931?

comment:14 Changed 13 years ago by charles

Actually... now, the per-torrent and overall speed reporting should be more in sync than before, since they're all reading from the same page. However, the overall up/down speed may still be greater than the sum of the groups' speeds because of extra protocol overhead in handshakes. This difference is intentional and is not a bug.

comment:15 Changed 13 years ago by charles

  • Type changed from Enhancement to Bug

comment:16 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:17 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
Note: See TracTickets for help on using tickets.