Opened 13 years ago

Closed 13 years ago

#1270 closed Bug (invalid)

transmisson goes to core during json query

Reported by: spry Owned by: charles
Priority: Normal Milestone: None Set
Component: Daemon Version: 1.33
Severity: Normal Keywords:
Cc:

Description

transmission goes to core during heavy queue json requests, and outputs

Invalid metadata Assertion failed: (!data->key), function callback, file json.c, line 114. Abort trap: 6 (core dumped)

Last 2 request was: Query = {"tag":"","method":"session-stats"} Result = {

"arguments": {

"session-stats": {

"activeTorrentCount": 20, "downloadSpeed": 0, "pausedTorrentCount": 7, "torrentCount": 27, "uploadSpeed": 0

}

}, "result": "success"

}

Query = {"tag":"","method":"session-stats"}

Change History (7)

comment:1 Changed 13 years ago by spry

  • Component changed from Transmission to Daemon
  • Owner set to charles

I'll try to build debug from svn sometime later and reproduce, since it's 100% reproducible, if you'll need that. Or I can connect to your server, something like that. Generally, I'm writing win32 remote control for transmission, since web ui does not meet my requirements, and transmission-daemon fails during query queue from my software. I'll be happy to be able to help somehow.

comment:2 Changed 13 years ago by spry

Well, r6700 hangs (well, at least any json requests stop being served) after serveral json requests, Current head r6742 won't even start normally, so I'll try again some time later

comment:3 Changed 13 years ago by spry

Something really strange happens. Unfortunately I can not check the bug on trunk debug revision, since it refuses to work anything like normal even with web interface, not responding via /rpc, but even web client loads extremely slow, so it seems there is a problem in embedded http server. :( So, please, whenever the trunk will be stable, keep me in touch

comment:4 Changed 13 years ago by charles

spry: I'm not seeing the behaviour you describe in the previous two comments...

comment:5 Changed 13 years ago by spry

I've reverted to version 1.33, but built it with -g instead of -O2, and those crashes are gone, I'll try to reproduce it with -O2 and -g..

comment:6 Changed 13 years ago by charles

I'm wondering if there's something quirky with your build. I can't reproduce any of these problems... could you run the daemon in valgrind?

comment:7 Changed 13 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Feel free to reopen this ticket when more information is available.

Note: See TracTickets for help on using tickets.