Opened 13 years ago

Closed 8 years ago

Last modified 8 years ago

#1272 closed Bug (worksforme)

Transmission Remote does not work in Google Chrome

Reported by: greatcaffeine Owned by: Gimp
Priority: Normal Milestone: None Set
Component: Web Client Version: 1.33
Severity: Normal Keywords: google, chrome, remote, web
Cc: my.n@…

Description

I am unable to connect to the Transmission web interface when using Google Chrome. I have tested the web interface with Safari 3, Safari 4, and Firefox 3 and it works as expected with those browsers. When using Chrome, it says "Connection Failed. Could not connect to the server. You may need to reload the page to connect." I am then presented with the option to dismiss the error or get details. Reloading the page does not resolve the issue.

I'm not sure if this is your fault or just Google Chrome being weird, but I thought I'd go ahead and make a ticket so the issue is logged.

I'll be attaching a small picture of the error.

Attachments (1)

chrome-error.png (16.0 KB) - added by greatcaffeine 13 years ago.
Chrome web interface error

Download all attachments as: .zip

Change History (12)

Changed 13 years ago by greatcaffeine

Chrome web interface error

comment:1 Changed 13 years ago by gothicx

It works fine here with Google Chrome version 0.2.149.29.

comment:2 Changed 13 years ago by tylerdurden

Confirmed working in 0.2.149.30 w/ 1.3.4

greatcaffeine: can you provide more information, what OS, ver of Chrome, etc.

comment:3 Changed 13 years ago by tylerdurden

Also, verified working in 1.33

comment:4 Changed 13 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

comment:5 Changed 13 years ago by axelgenus

  • Resolution worksforme deleted
  • Status changed from closed to reopened

comment:6 Changed 13 years ago by spry

Such error rises not only in Google Chrome, but in Firefox 3 for example. But in my case it happens often after some time of work. This may be connected with internet connection...

comment:7 Changed 13 years ago by spry

Currenly I'm using head r6871 and Chrome works fine, at least not worse than Firefox. So, I suggest that it is some network trouble. Also, I suppose, that if possible, web should be fixed somehow to be able to retry failed RPC query..

comment:8 Changed 13 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed

Closing this ticket again.

axelgenus: From that thread it appears that you're using 1.34 or even 1.33. Please try out a more recent version.

comment:9 Changed 8 years ago by saymonz

  • Cc my.n@… added
  • Priority changed from Normal to Low
  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 1.33 to 2.81

I face this exact same problem here, don't know if it's a problem in transmission, nginx or Chrome, but here's my setup details:

Server side: OS: Arch Linux, up to date with official repositories. Transmission 2.81, Nginx 1.4.2

Here's the relevant part of my nginx config file:

    server {
        server_name     control.domain;
        root            /home/control.domain;

        location = /robots.txt      { access_log off; log_not_found off; }
        location = /favicon.ico     { access_log off; log_not_found off; } 
        location ~ /\.ht            { deny  all; }

        access_log  /var/log/nginx/$http_host.access.log;

        auth_basic              on;
        auth_basic_user_file    /srv/http/auth.db;

        location /transmission {
            proxy_read_timeout  300;
            proxy_pass_header   X-Transmission-Session-Id;
            proxy_set_header    X-Forwarded-Host $host;
            proxy_set_header    X-Forwarded-Server $host;
            proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
            proxy_pass          http://localhost:9091/transmission;
        }

        include	ssl.conf;
    }

Transmission is configured to listen on localhost only and don't ask for any authentification since I do this with nginx.

Client side: OS: Windows 8, up to date

WebUI works perfectly fine with Internet Explorer (10.0.9200.16660) and Firefox (23.0.1) but don't work with Chrome (29.0.1547.66 m).

Previously, I had a similar setup but with Ubuntu and Apache instead of Arch andNginx, and the WebUI worked fine in every browsers, so it may be a problem with another software but maybe those details may help to find a solution.

comment:10 Changed 8 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed

This is likely an issue with other software.

comment:11 Changed 8 years ago by livings124

  • Priority changed from Low to Normal
  • Version changed from 2.81 to 1.33
Note: See TracTickets for help on using tickets.