Opened 13 years ago

Closed 13 years ago

#1277 closed Bug (fixed)

Mac Client doesn't respect RPC torrent-add flags

Reported by: bgilmore Owned by: livings124
Priority: Normal Milestone: 1.40
Component: Mac Client Version: 1.33
Severity: Normal Keywords:
Cc:

Description

The torrent-add RPC method documented in rpc-spec.txt enumerates two optional fields (paused and download-dir) that are respected by transmission-daemon, but not by the Mac client. The other documented flags work as intended.

The following request was used for testing both clients:

POST /transmission/rpc HTTP/1.1
TE: deflate,gzip;q=0.3
Connection: TE, close
Host: localhost:9090
User-Agent: P2P::Transmission 0.05
Content-Length: 248
Content-Type: application/x-www-form-urlencoded

{
   "method" : "torrent-add",
   "tag" : 42174,
   "arguments" : {
      "download-dir" : "/Users/bgilmore/tmp",
      "filename" : "/Users/bgilmore/Documents/debian-40r4a-amd64-DVD-1.iso.torrent",
      "peer-limit" : 30,
      "paused" : 1
   }
}

Change History (3)

comment:1 Changed 13 years ago by livings124

  • Status changed from new to assigned

comment:2 Changed 13 years ago by livings124

[6844] should take care of the paused state issue.

comment:3 Changed 13 years ago by livings124

  • Milestone changed from None Set to 1.40
  • Resolution set to fixed
  • Status changed from assigned to closed

Both of these issues should be taken care of.

Note: See TracTickets for help on using tickets.