Opened 13 years ago

Closed 13 years ago

Last modified 12 years ago

#1283 closed Bug (fixed)

Default pthread stack too small on OpenBSD

Reported by: naddy Owned by:
Priority: Normal Milestone: 1.40
Component: libtransmission Version: 1.34
Severity: Normal Keywords: pthreads, OpenBSD
Cc:

Description

At least on OpenBSD, transmission 1.34 will crash as soon as the web/remote interface is accessed because the http thread runs out of pthread stack space. The default pthread stack size on OpenBSD is 64 kB. Doubling this fixes the problem.

Attachments (1)

libtransmission_platform_c.patch (910 bytes) - added by naddy 13 years ago.

Download all attachments as: .zip

Change History (6)

Changed 13 years ago by naddy

comment:1 Changed 13 years ago by mezz

Interesting.. I am a bit surpise about that OpenBSD hasn't increase it yet. NetBSD and FreeBSD already have done. I remember we had to add a few of workaround patches for GNOME stuff with stacksizes, then finally FreeBSD increased it (in libc_r, libpthread and libthr) and we can removed the workaround patches in our GNOME.

http://lists.freebsd.org/pipermail/cvs-src/2005-May/046143.html

                32-bit  64-bit
  main thread     2MB     4MB
  other threads   1MB     2MB


I think, it's good time for OpenBSD to increase the stacksizes while many OSs have bigger stacksizes. :-)

BTW: To avoid misunderstand or not good English grammar of mine. I have no object with this patch, so up to the developers. Just merely add comments of my memory. :-)

comment:2 follow-up: Changed 13 years ago by muks

This bug is a duplicate of #1217 (if the crash is indeed in decide_what_to_do() which was fixed in [6648], but didn't make it into the 1.3 branch.

comment:3 in reply to: ↑ 2 Changed 13 years ago by naddy

Yes, this is indeed the same crash as in #1217.

comment:4 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40
  • Resolution set to fixed
  • Status changed from new to closed

fixed in r6800; we're not using shttpd anymore.

comment:5 Changed 12 years ago by charles

  • Component changed from Transmission to libtransmission
Note: See TracTickets for help on using tickets.