Opened 12 years ago

Closed 12 years ago

#1293 closed Bug (fixed)

Crash on startup due to passing uninitialized rectangle to [View initWithFrame:] (6793)

Reported by: Waldorf Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.34
Severity: Blocker Keywords:
Cc:

Description


Attachments (3)

Transmission_2008-09-21-232328_G4.crash (20.3 KB) - added by Waldorf 12 years ago.
Transmission_2008-09-22-231446_G4.crash (20.3 KB) - added by Waldorf 12 years ago.
Transmission_2008-09-26-230343_G4.crash (19.9 KB) - added by Waldorf 12 years ago.
Updated crashlog, to reflect changes in the code

Download all attachments as: .zip

Change History (12)

Changed 12 years ago by Waldorf

comment:1 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

If I had to get, application enhancer would be the cause of issues like this.

Changed 12 years ago by Waldorf

comment:2 Changed 12 years ago by Waldorf

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Replying to livings124:

nope, application enhancer ain't causing it. Btw, 1.34 (release) is working perfectly.

comment:3 Changed 12 years ago by Waldorf

As far as I've tested, 1.33Z-r6743 is the most recent working version.

comment:4 Changed 12 years ago by livings124

Is that from past experiences, or did you just test that, since there's no reason that I can tell why it would break after that. It might be a change from 10.5.4 -> 10.5.5, since I don't have 10.5.5 installed yet.

comment:5 Changed 12 years ago by Waldorf

  • Summary changed from Crash on startup due to uncaught exception 'NSInternalInconsistencyException' (6793) to Crash on startup due to passing uninitialized rectangle to [View initWithFrame:] (6793)

I did install 10.5.5. I've tested this with APE removed. Also, the nightly is working on another another mac, also running 10.5.5.

From the crashlog, I get the idea it is being caused by (wrongly?) drawing some of the badger code.

Changed 12 years ago by Waldorf

Updated crashlog, to reflect changes in the code

comment:6 Changed 12 years ago by livings124

That code hasn't changed forever. Can you test that it works on 6743 and not 6744 (or find where exactly it breaks)?

comment:7 Changed 12 years ago by livings124

Can you try [6806]?

comment:8 Changed 12 years ago by Waldorf

It breaks at: r6785 (last nightly build before that was r6749). Will try r6806 in a moment.

comment:9 Changed 12 years ago by Waldorf

  • Resolution set to fixed
  • Status changed from reopened to closed

Fixed in [6806]

Note: See TracTickets for help on using tickets.