Opened 13 years ago

Closed 12 years ago

#1308 closed Bug (fixed)

Transmission forgets it is verifying data

Reported by: adamc Owned by: charles
Priority: Normal Milestone: 1.40
Component: Transmission Version: 1.34
Severity: Normal Keywords:
Cc:

Description

Transmission attempts to download an already completed file if the torrent is added before verification completes in the file options dialog.

Steps to reproduce: 1 - Ensure "Display options dialog" option is enabled in preferences 2 - Load torrent that has already been completed (transmission starts verifying data in the file options window) 3 - Click the add button before file verification is complete 4 - The file is set to 0% complete and downloading begins again.

Tested in gtk+ version 1.34, may occur in other versions as well.

Change History (3)

comment:1 Changed 12 years ago by charles

  • Component changed from GTK+ Client to Transmission
  • Owner charles deleted

This is a general Transmission issue, though I don't know if the mac client shows this behavior or not. The issue is that if you start a torrent that's in the process of being verified, the verify process is interrupted.

comment:2 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
  • Owner set to charles
  • Status changed from new to assigned

comment:3 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r6975

Note: See TracTickets for help on using tickets.