Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1323 closed Bug (invalid)

make install fails on Ubuntu Intrepid Beta

Reported by: smmalis Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.34
Severity: Normal Keywords:
Cc:

Description

make install fails with the following error message:

/bin/mkdir: cannot create directory `/usr/local/share/transmission': No such file or directory

Trying to install the latest version from svn.

Attachments (1)

log.txt (10.5 KB) - added by smmalis 12 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 Changed 12 years ago by charles

A little more context here would be welcomed...

comment:2 Changed 12 years ago by charles

it appears to be failing to install here because /usr/local/share/transmission doesn't exist. Do you have write permissions in /usr/local/share?

can you attach a file with the entire `make install' log?

what version of automake/autoconf ships with intrepid?

what are the permissions of /usr/local and /usr/local/share? do you have write permissions to both of them?

comment:3 Changed 12 years ago by smmalis

automake version: 1.10.1-3 autoconf version: 2.61-7 "make install" is run under "sudo", so permissions shouldn't be a problem. Log of make install is attached.

Changed 12 years ago by smmalis

comment:4 Changed 12 years ago by charles

what do you get when running this in a bash shell as root:

% test -z "/usr/local/share/transmission/web"
/bin/mkdir -p "/usr/local/share/transmission/web"

comment:5 Changed 12 years ago by smmalis

I get:

test: extra argument `/bin/mkdir'

comment:6 Changed 12 years ago by charles

gah, trac ate the markup, I think.

% test -z "/usr/local/share/transmission/web" || /bin/mkdir -p "/usr/local/share/transmission/web" 

comment:7 Changed 12 years ago by smmalis

  • Resolution set to invalid
  • Status changed from new to closed
/bin/mkdir: cannot create directory `/usr/local/share/transmission': Permission denied

Interesting. So it is permissions. You'd think sudo would overcome that. Maybe its an ubuntu bug?

comment:8 Changed 12 years ago by smmalis

  • Resolution invalid deleted
  • Status changed from closed to reopened

Ok, I think this is a problem in the makefile. If I just do "sudo mkdir -p /usr/local/share/transmission/web" it works fine. I think the problem is that "test -z". Is it necessary?

The other thing I noticed is that when make tries to install the icons, mkdir returns a problem. I think it just needs to be mkdir -p.

comment:9 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from reopened to closed

smmalis: Transmission has no control over those parts of the Makefile. That's all generated by automake/autoconf and probably you should report it upstream to automake to get an opinion from someone who knows more about this than us.

comment:10 Changed 12 years ago by smmalis

For anyone interested in following the automake bug report, go to the following link, enter 530 and hit view. http://sources.redhat.com/cgi-bin/gnatsweb.pl?database=automake

Note: See TracTickets for help on using tickets.