Opened 12 years ago

Closed 12 years ago

#1348 closed Bug (invalid)

Crash When Setting Web Interface Port to 80

Reported by: atc Owned by: charles
Priority: High Milestone: None Set
Component: GTK+ Client Version: 1.34
Severity: Critical Keywords:
Cc:

Description

Transmission crashes outright - completely shuts down - when setting the port for the web interface to 80.

To reproduce:

  1. Go to Edit->Preferences
  2. Select the 'Web' tab
  3. Set the listening port to 80
  4. Move focus out of the entry widget
  5. Crash.

Note: transmission will fail to open until you set the 'rpc-port' setting back to a value > 1000 in ~/.config/transmission/settings.json

Operating system: Debian (Sid/Unstable?) Linux

Platform: x86_64

Transmission was installed via apt-get, so a vanilla build (number 6778 according to help->about)

Change History (3)

comment:1 follow-up: Changed 12 years ago by atc

  • Cc placid@… removed

Can someone remove the email address from the 'CC:' field in this report? I get enough spam as it is :|

comment:2 in reply to: ↑ 1 Changed 12 years ago by atc

Replying to atc:

Can someone remove the email address from the 'CC:' field in this report? I get enough spam as it is :|

Umm, nevermind...

comment:3 Changed 12 years ago by smmalis

  • Resolution set to invalid
  • Status changed from new to closed

I may be wrong, but I believe this bug was fixed with the move from shttpd to evhttpd. The solution is to update to a newer build.

Note: See TracTickets for help on using tickets.