Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#1365 closed Bug (duplicate)

crash in g_markup_escape_text()

Reported by: simplexe Owned by:
Priority: Normal Milestone:
Component: GTK+ Client Version: 1.34
Severity: Critical Keywords:
Cc:

Description

[simplexe@LD-IT-04 ~]$ uname -a Linux LD-IT-04 2.6.27-ARCH #1 SMP PREEMPT Sun Oct 12 15:16:25 CEST 2008 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz GenuineIntel? GNU/Linux

Attachments (1)

transmission-bugreport.txt (244.5 KB) - added by simplexe 11 years ago.
bugreport

Download all attachments as: .zip

Change History (7)

Changed 11 years ago by simplexe

bugreport

comment:1 follow-up: Changed 11 years ago by charles

There is not enough information here to fix this bug. What were you doing when it crashed? Can you provide a backtrace from gdb?

comment:2 in reply to: ↑ 1 Changed 11 years ago by simplexe

Replying to charles:

There is not enough information here to fix this bug. What were you doing when it crashed? Can you provide a backtrace from gdb?

Starting program: /usr/bin/transmission (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) (no debugging symbols found) [Thread debugging using libthread_db enabled] [New Thread 0xb71946c0 (LWP 5806)] [New Thread 0xb64e8b90 (LWP 5807)] [New Thread 0xb5667b90 (LWP 5968)] [New Thread 0xb4e66b90 (LWP 5969)] [New Thread 0xb4665b90 (LWP 5970)] [Thread 0xb4e66b90 (LWP 5969) exited] [Thread 0xb4665b90 (LWP 5970) exited] [New Thread 0xb4e66b90 (LWP 5971)] [Thread 0xb5667b90 (LWP 5968) exited] [New Thread 0xb5667b90 (LWP 5972)] [Thread 0xb5667b90 (LWP 5972) exited] [New Thread 0xb4665b90 (LWP 5973)] [Thread 0xb4665b90 (LWP 5973) exited] [New Thread 0xb3e64b90 (LWP 5974)] [Thread 0xb4e66b90 (LWP 5971) exited] [New Thread 0xb4e66b90 (LWP 5975)] [Thread 0xb4e66b90 (LWP 5975) exited] [Thread 0xb3e64b90 (LWP 5974) exited] [New Thread 0xb3e64b90 (LWP 5980)] [New Thread 0xb3262b90 (LWP 5981)] [New Thread 0xb2a61b90 (LWP 5982)] [Thread 0xb3262b90 (LWP 5981) exited] [Thread 0xb2a61b90 (LWP 5982) exited]

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated [Thread 0xb3e64b90 (LWP 5980) exited] [New Thread 0xb2a61b90 (LWP 6013)] [New Thread 0xb3262b90 (LWP 6014)] [New Thread 0xb2260b90 (LWP 6015)] [New Thread 0xb1a5fb90 (LWP 6016)] [New Thread 0xb125eb90 (LWP 6017)] [New Thread 0xb0a5db90 (LWP 6018)] [New Thread 0xb025cb90 (LWP 6019)] [New Thread 0xafa5bb90 (LWP 6020)] [New Thread 0xaf25ab90 (LWP 6021)] [New Thread 0xaea59b90 (LWP 6022)] [Thread 0xb025cb90 (LWP 6019) exited] [Thread 0xb2a61b90 (LWP 6013) exited] [Thread 0xb2260b90 (LWP 6015) exited] [Thread 0xb125eb90 (LWP 6017) exited] [Thread 0xb0a5db90 (LWP 6018) exited] [Thread 0xafa5bb90 (LWP 6020) exited] [Thread 0xaf25ab90 (LWP 6021) exited] [Thread 0xaea59b90 (LWP 6022) exited] [Thread 0xb3262b90 (LWP 6014) exited] [New Thread 0xb2a61b90 (LWP 6025)] [Thread 0xb2a61b90 (LWP 6025) exited] [New Thread 0xb2260b90 (LWP 6026)] [Thread 0xb2260b90 (LWP 6026) exited] [New Thread 0xb0a5db90 (LWP 6027)] [Thread 0xb0a5db90 (LWP 6027) exited] [New Thread 0xaea59b90 (LWP 6028)] [Thread 0xb1a5fb90 (LWP 6016) exited] [New Thread 0xb1a5fb90 (LWP 6034)] [Thread 0xb1a5fb90 (LWP 6034) exited] [New Thread 0xb1a5fb90 (LWP 6039)] [New Thread 0xb3262b90 (LWP 6040)] [Thread 0xb3262b90 (LWP 6040) exited] [Thread 0xb1a5fb90 (LWP 6039) exited] [New Thread 0xb1a5fb90 (LWP 6041)] [Thread 0xb1a5fb90 (LWP 6041) exited]

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated [Thread 0xaea59b90 (LWP 6028) exited]

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated

(transmission:5806): Gtk-WARNING : GtkSpinButton?: setting an adjustment with non-zero page size is deprecated [New Thread 0xb1a5fb90 (LWP 6086)] [New Thread 0xb3262b90 (LWP 6087)] [Thread 0xb1a5fb90 (LWP 6086) exited] [Thread 0xb3262b90 (LWP 6087) exited] [New Thread 0xb3262b90 (LWP 6687)] [Thread 0xb3262b90 (LWP 6687) exited] [New Thread 0xb3262b90 (LWP 6719)] [Thread 0xb3262b90 (LWP 6719) exited] [New Thread 0xb3262b90 (LWP 6884)] [New Thread 0xb1a5fb90 (LWP 6885)] [New Thread 0xb125eb90 (LWP 6886)] [New Thread 0xb025cb90 (LWP 6887)] [New Thread 0xafa5bb90 (LWP 6888)] [New Thread 0xaf25ab90 (LWP 6889)] [New Thread 0xae258b90 (LWP 6890)] [New Thread 0xada57b90 (LWP 6891)] [New Thread 0xad256b90 (LWP 6892)] [New Thread 0xaca55b90 (LWP 6893)] [Thread 0xafa5bb90 (LWP 6888) exited] [Thread 0xb125eb90 (LWP 6886) exited] [Thread 0xb1a5fb90 (LWP 6885) exited] [Thread 0xb025cb90 (LWP 6887) exited] [Thread 0xaf25ab90 (LWP 6889) exited] [Thread 0xae258b90 (LWP 6890) exited] [Thread 0xada57b90 (LWP 6891) exited] [Thread 0xad256b90 (LWP 6892) exited] [Thread 0xaca55b90 (LWP 6893) exited] [Thread 0xb3262b90 (LWP 6884) exited] [New Thread 0xb3262b90 (LWP 7267)] [Thread 0xb3262b90 (LWP 7267) exited] [New Thread 0xb3262b90 (LWP 8714)] [Thread 0xb3262b90 (LWP 8714) exited] [New Thread 0xb3262b90 (LWP 8754)] [Thread 0xb3262b90 (LWP 8754) exited] [New Thread 0xb3262b90 (LWP 14888)] [New Thread 0xb025cb90 (LWP 14889)] [New Thread 0xb1a5fb90 (LWP 14890)] [New Thread 0xb125eb90 (LWP 14891)] [Thread 0xb025cb90 (LWP 14889) exited] [Thread 0xb1a5fb90 (LWP 14890) exited] [Thread 0xb125eb90 (LWP 14891) exited] [Thread 0xb3262b90 (LWP 14888) exited] [New Thread 0xb3262b90 (LWP 15202)] [Thread 0xb3262b90 (LWP 15202) exited] [New Thread 0xb3262b90 (LWP 15246)] [Thread 0xb3262b90 (LWP 15246) exited]

Program received signal SIGSEGV, Segmentation fault. [Switching to Thread 0xb71946c0 (LWP 5806)] 0xb7830958 in g_markup_escape_text () from /usr/lib/libglib-2.0.so.0 Current language: auto; currently asm

comment:3 Changed 11 years ago by charles

  • Milestone changed from None Set to 1.40
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket is a duplicate of #1314, which is fixed in trunk

comment:4 Changed 11 years ago by charles

  • Component changed from Transmission to GTK+ Client
  • Summary changed from Transmission Crash to crash in g_markup_escape_text()

comment:5 Changed 11 years ago by charles

  • Severity changed from Normal to Critical

comment:6 Changed 11 years ago by charles

  • Milestone 1.40 deleted
Note: See TracTickets for help on using tickets.