Opened 12 years ago

Closed 12 years ago

#1380 closed Bug (duplicate)

Transmission 1.34 (6778) Segmentation fault in Ubuntu 8.10 (segfault at b6436000 ip b78a1da8 sp bfe502e0 error 4 in libglib-2.0.so.0.1800.2[b7864000+b5000])

Reported by: dkorzhevin Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.34
Severity: Normal Keywords:
Cc:

Description

Segfault, when i change size of window (transmission - torent details - Peers)

/var/log/syslog:

Oct 24 20:35:40 korg-desktop kernel: [22817.443104] transmission[11477]: segfault at b6436000 ip b78a1da8 sp bfe502e0 error 4 in libglib-2.0.so.0.1800.2[b7864000+b5000]

Ubuntu 8.10 all updates included

kernel: Linux korg-desktop 2.6.27-7-generic #1 SMP Fri Oct 24 06:42:44 UTC 2008 i686 GNU/Linux

dpkg -p transmission-common:

Priority: optional Section: net Installed-Size: 456 Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@…> Architecture: all Source: transmission Version: 1.34-0ubuntu2 Size: 142678 Description: free, lightweight BitTorrent? client

Transmission is a simple BitTorrent? client. It features a very simple, intuitive interface (gui and command-line) on top on an efficient, cross-platform back-end. . This package contains the common files for the different transmission versions.

Homepage: http://www.transmissionbt.com/ Original-Maintainer: Leo Costela <costela@…>

dpkg -p transmission-gtk:

Package: transmission-gtk Priority: optional Section: net Installed-Size: 2076 Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@…> Architecture: i386 Source: transmission Version: 1.34-0ubuntu2 Replaces: transmission (<< 0.6.1.dfsg-2) Depends: libc6 (>= 2.4), libcurl3 (>= 7.16.2-1), libdbus-glib-1-2 (>= 0.71), libglib2.0-0 (>= 2.16.0), libgtk2.0-0 (>= 2.14.1), libnotify1 (>= 0.4.4), libnotify1-gtk2.10, libssl0.9.8 (>= 0.9.8f-5), libx11-6, transmission-common (= 1.34-0ubuntu2) Size: 314184 Description: free, lightweight BitTorrent? client (graphical interface)

Transmission-gtk is a GTK-based BitTorrent? client. It features a very simple, intuitive interface on top on an efficient, cross-platform back-end.

Homepage: http://www.transmissionbt.com/ Original-Maintainer: Leo Costela <costela@…>

Attachments (2)

xdg.bz2 (4.5 KB) - added by dkorzhevin 12 years ago.
transmission strace (i split strace-transmission to many files, this is last file with crash)
gdb-transmission.bz2 (1.4 KB) - added by dkorzhevin 12 years ago.
GDB log file for crash in transmission

Download all attachments as: .zip

Change History (5)

comment:1 Changed 12 years ago by costela

  • Priority changed from High to Normal
  • Severity changed from Critical to Normal

Can you please add some more details, like strace output?

I can't reproduce the problem here, but from the little description you gave this could very well be a problem with something else, since the segfault is apparently inside glib.

Cheers

Changed 12 years ago by dkorzhevin

transmission strace (i split strace-transmission to many files, this is last file with crash)

comment:2 Changed 12 years ago by dkorzhevin

Please look at http://trac.transmissionbt.com/attachment/ticket/1380/xdg.bz2 This is part of strace log with transmission crash. If you need - i can mail full size strace log to your's e-mail.

Changed 12 years ago by dkorzhevin

GDB log file for crash in transmission

comment:3 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

dkorzhevin, thanks for the backtrace. Its money quote:

Program received signal SIGSEGV, Segmentation fault.
---Type <return> to continue, or q <return> to quit---
[Switching to Thread 0xb6ebc720 (LWP 12029)]
0xb7891da8 in g_markup_escape_text () from /usr/lib/libglib-2.0.so.0

this is a duplicate of #1314.

Note: See TracTickets for help on using tickets.