Opened 12 years ago

Closed 12 years ago

#1381 closed Bug (fixed)

Transmission doesn't resize properly

Reported by: smmalis Owned by: charles
Priority: Normal Milestone: 1.40
Component: GTK+ Client Version: 1.34
Severity: Normal Keywords:
Cc:

Description

Enlarging the Transmission window enlarges the actual window, but not the contents of the window, creating a wierd effect. See screenshot.

Attachments (1)

Screenshot.png (35.2 KB) - added by smmalis 12 years ago.

Download all attachments as: .zip

Change History (14)

Changed 12 years ago by smmalis

comment:1 Changed 12 years ago by Shutnik

I also have that problem sometimes.

comment:2 Changed 12 years ago by charles

smmalis: what svn revision are you using?

comment:3 Changed 12 years ago by smmalis

6951

comment:4 Changed 12 years ago by livings124

#1391 - applies to details window as well

comment:5 Changed 12 years ago by charles

  • Status changed from new to assigned

comment:6 follow-up: Changed 12 years ago by Rolcol

I just had this happen. It happened to me when I manually tried to update the blocklist and it said it updated with only "22" total. The window showing the updated total had shrunk and every transmission window, whether it be the one containing the torrents or the preferences, would resize without adjusting the size of the contents inside.

comment:7 in reply to: ↑ 6 Changed 12 years ago by Rolcol

I forgot to add that I'm using the very latest SVN trunk. 6994. The only way I found of getting back to normal was to quit the application and start it up again.

comment:8 Changed 12 years ago by smmalis

When it happened to me, quitting and restarting did nothing. Since then, however, I have been unable to reproduce it.

comment:9 Changed 12 years ago by charles

it seems to happen sometimes when testing the port or updating the blocklist in the preferences dialog...

comment:10 Changed 12 years ago by charles

  • Version changed from 1.34+ to 1.34

Changing from 1.34+ to 1.34, since this behavior isn't new in the nightlies

comment:11 Changed 12 years ago by charles

smmalis, RolCol?, Shutnik: could you test and see if r7029 fixes this bug?

comment:12 Changed 12 years ago by Rolcol

This bug appears randomly for me. I don't see any problems yet.

comment:13 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
  • Resolution set to fixed
  • Status changed from assigned to closed

I think r7029 fixed it, and I can't seem to trigger it anymore either.

Marking as fixed, but since it is kind of hard to reproduce in the first place, all of you are encouraged to reopen this ticket if the old behavior shows up again.

Note: See TracTickets for help on using tickets.