Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1401 closed Bug (fixed)

Error building: libnotify can't handle G_DISABLE_SINGLE_INCLUDES

Reported by: smmalis Owned by: charles
Priority: Normal Milestone: 1.40
Component: GTK+ Client Version: 1.34+
Severity: Normal Keywords:
Cc:

Description

{{{In file included from /usr/include/libnotify/notification.h:28,

from /usr/include/libnotify/notify.h:27, from notify.c:29:

/usr/include/gtk-2.0/gtk/gtkversion.h:28:2: error: #error "Only <gtk/gtk.h> can be included directly."}}}

Change History (4)

comment:1 Changed 12 years ago by Rolcol

This is the same thing I tried to explain in the IRC channel. So it's not just me...

comment:2 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
  • Status changed from new to assigned

I can fix this in the local build, but it's being caused by a bug in libnotify... could you report this upstream too?

comment:3 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r7001.

comment:4 Changed 12 years ago by charles

  • Summary changed from Error building to Error building: libnotify can't handle G_DISABLE_SINGLE_INCLUDES
Note: See TracTickets for help on using tickets.