Opened 12 years ago

Closed 12 years ago

#1413 closed Bug (worksforme)

Incorrect ratio reported.

Reported by: d-man97 Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 1.42
Severity: Minor Keywords:
Cc:

Description

Installed Ubuntu 8.10 and decided to try Transmission instead of installing Azureus. Found out it had Bluetack support and was quite impressed, since moblock uses around 30MB RAM!!!

Problem came when my first and only (2) downloads were finished. One had a ratio of 1.73 (maybe higher, but definitely not into the 1.8 range). The second had a ratio of a little over 2.0, but not up to 2.1.

Overall ratio was reported as 1.06!!! Both files were the same size, roughly. How is this possible, it is simple arithmetic being done by a computer, how can it be THAT wrong?

I already removed the two files from the list, and have since started other downloads. Is there anything I can attach to prove this or to help figure out why?

I put this as low priority and minor severity because I couldn't give a crap about my ratio (as long as its over 1.0). Maybe others would care more, but it's my ticket and I'll do what I want. ;)

Attachments (1)

Screenshot-Transmission.png (23.2 KB) - added by d-man97 12 years ago.

Download all attachments as: .zip

Change History (15)

comment:1 Changed 12 years ago by charles

Can you attach a screenshot?

comment:2 Changed 12 years ago by d-man97

Like I said, I already cleared those first two torrents and started on two more. (I didn't think it was worth reporting a bug at first.) Would anything be kept in any log file?

I will wait for these next two to finish and see if I can deduce/prove the error is ongoing. OR Can I reset the ratio/start from scratch? (Presumably by deleting a ~/.<something> directory?)

Changed 12 years ago by d-man97

comment:3 Changed 12 years ago by d-man97

Maybe that shot will help...

Ratio, after first 2 downloads, was reported as 1.06 (should have been ~1.9).

Now, I downloaded 1.4GB and uploaded 1.4GB and ratio is at 0.89, as seen in image.

1.48GB/1.40GB = 1.06 (Prior 2 torrents) <--Incorrect, but using it for arguments sake. 1.40GB/1.40GB = 1.00 (Recent 2 torrents)

2.88GB/2.40GB = 1.025 BUT, as the screen-shot shows, it is now magically 0.89!!

Now, if I correct it from the very beginning: File 1

DL: 0.70GB UL: 1.26GB Ratio: ~1.8

File 2

DL: 0.70GB UL: 1.40GB Ratio: ~2.0

File 3 (In screen-shot)

DL: 0.70GB UL: 1.00GB Ratio: ~1.4

File 4 (In screen-shot)

DL: 0.70GB UL: 0.45GB Ratio: ~0.6

Totals

DL: 2.80GB UL: 4.11GB Ratio: ~1.47 <-- This is what it should be!!

I might have gotten a bit wordy, hope you can follow.

comment:4 Changed 12 years ago by d-man97

Crap, the WikiFormatting messed that up...horribly. It's not even close to what I typed into the box.

Anyways, the point is, whether I use the correct ratios, or the incorrect ratios, the ratio is still being reported wrong.

comment:5 Changed 12 years ago by charles

Yes, I see what you're saying, but I'm not getting that behavior... hm.

If you want to start the experiment again from scratch, you can reset the global stats by pressing the reset button in the View > Statistics dialog, and also just by deleting the file ~/.config/transmission/stats.json.

You might also look at the Details dialog for each of the four torrents to see how much Transmission thinks you've downloaded for each torrent, and compare that to how large the torrent actually is. However since we're working from incomplete data at this point, IMO it's better to start from scratch by resetting the stats and starting with new torrents.

comment:6 Changed 12 years ago by livings124

Did you remove the data while downloading and readd it? Ratio is calculated using the amount you've downloaded since you've added it, or the total size if you've downloaded nothing since adding (ie added for seeding).

comment:7 Changed 12 years ago by d-man97

According to my stats file's session-count, I had restarted Transmission during/after transfers, but I have never removed and re-added a torrent.

count 1 was from me opening transmission to see the program/features count 2 was from my initial 2 d/l's <removed initial 2 torrents when they finished> count 3 was for my second 2 d/l's count 4 was done by me for testing purposes <removed second 2 torrents at this point>

Since I removed them, and renamed/moved the files, I cannot check the details page. I will delete the stats file and start from scratch (not removing them this time). I'll get back if the problem resurfaces.

comment:8 Changed 12 years ago by charles

  • Resolution set to invalid
  • Status changed from new to closed

Sounds like a plan. Please reopen this ticket if/when there's more to go on. And, thanks for taking the time to fill out a ticket in the first place. :)

comment:9 Changed 12 years ago by kisaa

  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 1.34 to 1.42

Confirm this bug. In my case, there is only one torrent, without adding/delete, just pause it and resume again. After resume, displayed ratio is only half from one what was before. Also, incorrect data are stored in ~/.config/transmission/stats.json: "downloaded-bytes" parameter is ~2x greater than real downloaded data. At this moment, I have 641 MiB downloaded, and stored value is "downloaded-bytes": 1409860380

comment:10 Changed 12 years ago by d-man97

Thank you kissa.

I can confirm this behavior too. It took awhile to figure out and when I did I neglected to reopen.

It seems as though when a torrent is paused, the ratio resets to 0.00 and can be confirmed by starting a torrent, let it run for a while, pause it, start it again and check the details page.

Can be very apparent if you run the torrent with an u/l speed of 0, let it get to 95% or so (almost done), pause the torrent, set u/l speed to unlimited, resume the torrent & let it finish. The ratio should be very low since 95% was d/l without u/l'ing any, yet the ratio will be quite high as transmission is only comparing the 5% d/l to whatever you have u/l'd in that time.

As far as the stats.json is concerned, I have not toyed with that.

P.S. I am still using Transmission 1.34 (6778) from Ubuntu repositories.

comment:11 Changed 12 years ago by livings124

d-man97: Do not report bugs for versions besides the latest.

comment:12 Changed 12 years ago by d-man97

Technically I wasn't reporting a bug, I was commenting on her response. Plus, apparently the same code is used, nothing was changed between versions; so wtf does it matter? Wouldn't you rather have more input? I could be using 0.1 and if the code is still the same in 22.3, then it doesn't matter. It is confirmed.

Also, if I report it to Ubuntu's bug tracker (for my version of Transmission), they will just tell me to report it upstream (AKA: here). So, until the Ubuntu repositories are updated with a stable, supported version...I am not going to upgrade to your latest version. To top it off, how often does Ubuntu's version match up with yours? I'd dare say once every 6 months and not for too long. As I am now, am I just screwed with support until Ubuntu 9.04 comes out? Then what happens 1 month later when you guys update but don't send it off to Ubuntu repositories? I am screwed yet again. [This is a horrendous problem with distro's, not you guys: there is no way to upgrade to latest versions without cherry-picking them and going to each package's website, not very effective for staying current; so, like many others, I simply rely on the distro upgrades.] This is the best I can do.

If you really don't want input on non-latest versions, it is a simple fix: take the 'Version:' drop-down box away; otherwise, you are telling me that you don't care what version the bug is for.

Finally, don't comment on kissa's post, or help resolve it in any way, just yell at me some more why don't ya?


Anyways, after re-reading the previous posts I can't help but think: is this even a bug? Or, is it the way it was programmed: "Ratio is calculated using the amount you've downloaded since you've added it".

If it is removed/added/re-verified, I assume that counts as "adding it" and will reset the ratio.

But, if it's paused/resumed, does that count as "adding it" too? If so, then this might need to be changed to Enhancement, in the hopes that individual, persistent torrent ratio tracking will be added.

comment:13 Changed 12 years ago by livings124

Ratio is amount uploaded over amount you have every downloaded (since adding the torrent). Only if you have never downloaded anything is the size of the file used (ie seeding).

And I could care less what your repo has - we have no control over that. Only report bugs based on current code. How can we fix bugs that might have already be fixed? We're not going on wild goose hunts here - only report on the most recent code. The version drop-down is so we know when bugs originate. We do not care about old bugs if they are not tested on the most recent code.

comment:14 Changed 12 years ago by charles

  • Resolution set to worksforme
  • Status changed from reopened to closed

d-man97: I'm not able to reproduce the behavior "ratio resets to zero after pausing & resuming" in 1.50. Could you try updating and see if the problem persists? There are Ubuntu builds available here, and 1.50 should be available sometime this weekend.

Note: See TracTickets for help on using tickets.