Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1424 closed Bug (fixed)

WIN32-specific ensureMinimumFileSize in inout.c fails to compile

Reported by: lubomir.marinov Owned by: charles
Priority: Normal Milestone: 1.40
Component: libtransmission Version: 1.34+
Severity: Normal Keywords:
Cc:

Description

The problem is specific to Windows. In r7054, tr_session no longer has the member doPreallocateFiles and thus causes the file libtransmission/inout.c to cause a compile-time error in the function ensureMinimumFileSize which is defined in a #ifdef WIN32.

Change History (3)

comment:1 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
  • Status changed from new to assigned
  • Version set to 1.34+

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in r7061

comment:3 Changed 12 years ago by charles

  • Summary changed from WIN32-specific ensureMinimumFileSize in inout.c fails to compile because tr_session has no member doPreallocateFiles to WIN32-specific ensureMinimumFileSize in inout.c fails to compile
Note: See TracTickets for help on using tickets.