Opened 13 years ago

Closed 13 years ago

#1427 closed Enhancement (fixed)

Files are kept open in read/write mode after a torrent finishes downloading

Reported by: lubomir.marinov Owned by: charles
Priority: Normal Milestone: 1.50
Component: libtransmission Version: 1.40
Severity: Normal Keywords:
Cc:

Description

When a video file finishes downloading with CLI (compiled on Windows Vista with MinGW for WINVER=0x0502), Windows Explorer doesn't create a thumbnail of it. If I stop CLI, Windows Explorer immediately creates the thumbnail. In the same scenario, Windows Media Player will also refuse to play the file stating that it's in use. Media Player Classic and MPlayer will play it though. I'm not really sure what's the expected behavior is so I'm just mentioning it in case it's something to be addressed because I don't think Azureus or BitTornado? caused such a thing for me while seeding. Maybe the file has to be reopened with FILE_SHARE_READ after finishing the download and going into seeding, I don't know...

Change History (3)

comment:1 Changed 13 years ago by charles

  • Version set to 1.40

comment:2 Changed 13 years ago by charles

  • Component changed from CLI to libtransmission
  • Milestone changed from None Set to 1.50
  • Status changed from new to assigned
  • Summary changed from Downloaded file in use while only seeding with Win32/MinGW CLI to Files are kept open in read/write mode after a torrent finishes downloading

This is a problem on other platforms too, so I'm going to tweak the Subject here a little...

comment:3 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk in r7687.

Fixed in 1.5x branch in r7688.

Note: See TracTickets for help on using tickets.