Opened 13 years ago

Closed 12 years ago

#1430 closed Bug (duplicate)

Disconnect ext. drive, transmisson starts to redownload on it.

Reported by: eisa01 Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 1.34+
Severity: Normal Keywords:
Cc: eisa01

Description

Running 1.40b1

I put my mac to sleep for the night. When I woke it up again this morning, I got a message from the OS that my external drive had been disconnected. But it did get back on my desktop at once.

Transmission had been running the whole time, but now it decided that any files that had been on the external drive was 0 %, and started to redownload them all. This is not good behaviour. It should pause the files if it detects they are missing, not start downloading them again to the same drive.

Additional testing: When I start the files again, one file went straight to rechecking. I don't know why, but it might be possible it had not started downloading any data yet. The others continue to download. When I do a pause and force a recheck, they show up as 100 % complete, even though they have written data to disk. So no data loss at least.

Change History (4)

comment:1 Changed 13 years ago by eisa01

  • Cc eisa01 added

comment:2 Changed 13 years ago by charles

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:3 Changed 13 years ago by livings124

#1949 is related

comment:4 Changed 12 years ago by charles

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #1765

Note: See TracTickets for help on using tickets.