Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1439 closed Bug (fixed)

Resizing columns in "File" tab in "Details" window causes hangup.

Reported by: marcabru Owned by: charles
Priority: Normal Milestone: 1.40
Component: GTK+ Client Version: 1.34
Severity: Normal Keywords:
Cc:

Description

I think, this bug is connected with the apparent resolution of another one (already closed): Cannot resize columns in 'File' tab of 'Details' window. Now it definitely does have the ability to resize the columns, but when I try to resize them, It apparently hang up, does not respond (but no freeze or crash), mouse moves but the mouse cursor stays as a "horizontal resize cursor" (<-->), no matter where I point to. I can only close the window with the escape key, and by hitting escape the app continues to behave normally.

Please help me confirming this. I use GNU/Linux i686 2.6.24, Ubuntu Hardy (8.04.1), xorg 7.3, GTK 2.12.9, Gnome 2.22.3, Transmission 1.40b1 (7032) installed from bortis's Launchpad PPA.

Expected behaviour: I should not be able to resize the last 3 columns, because there is no need to (theese are fixed-width strings, and the progress bar is ok with the default width). If I resize the first column, the whole list becomes wider, and a horizontal scrollbar appears.

Temporarily workaround: Resize the whole window instead of resizing any of the columns. Because now the list (as a whole) is width, resizing the window makes the first column wider.

Attachments (1)

transmission-1.40b1-column-resize-error.png (12.5 KB) - added by marcabru 12 years ago.
Screenshot which explains the problem,

Download all attachments as: .zip

Change History (8)

Changed 12 years ago by marcabru

Screenshot which explains the problem,

comment:1 Changed 12 years ago by charles

  • Milestone changed from None Set to 1.40
  • Status changed from new to assigned
  • Version changed from 1.34+ to 1.34

comment:2 Changed 12 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

What an odd bug. confirmed exactly as you described.

r7072 seems to fix it, at least for me.

comment:3 Changed 12 years ago by Rolcol

I also see this bug in the peers tab every once in a while. It's common but it doesn't happen every time.

comment:4 Changed 12 years ago by marcabru

charles, thx for the quick response and fix :-)

I tried the bugfix (latest svn):

  • Now the last 3 columns are not resizeable --> good.
  • I can even increase the width of the "File" column --> good.
  • If I try to make narrower the first column (than the default width), still hang up, had to press [Esc] to get back the mouse cursor --> wrong

(But why would I do that.)

To sum up, now it's functional but not totally fool-proof.

comment:5 Changed 12 years ago by marcabru

Rolcol is right: the peer list also fails to release mouse cursor after resizing. In, say, Nautilus, I can resize columns, or I can try to set smaller width than the minimum, and it does not hijack the state of the cursor. However in transmission it does.

comment:6 Changed 12 years ago by charles

marcabru: could you open that as a separate ticket, please?

comment:7 Changed 12 years ago by marcabru

I opened a separate ticket for the peer list http://trac.transmissionbt.com/ticket/1445 , but I do not think this particular error is solved. Now it's better, but the error still happens if trying to set smaller width.

Note: See TracTickets for help on using tickets.