Opened 13 years ago

Closed 13 years ago

#1443 closed Bug (fixed)

check for zlib fails when providing a specific path

Reported by: KyleK Owned by: charles
Priority: Normal Milestone: 1.40
Component: Transmission Version: 1.34+
Severity: Normal Keywords:
Cc:

Description

In configure: If you specify a non-default location for the zlib library using the --with-zlib=<path> option, configure will fail.

The cause for this is bad conditional checking in m4/check-zlib.m4. The test accepts the given value at first, but then overwrites it at line 23 with a default locaton.

Removing line 23 solves the issue.

(I've already informed the author of the m4 file, but he says he hasn't touched the script in years and wouldn't even know where on the web to fix the issue).

Change History (4)

comment:1 Changed 13 years ago by charles

  • Milestone changed from None Set to 1.40
  • Owner set to charles
  • Status changed from new to assigned
  • Version changed from 1.34 to 1.34+

comment:2 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

I love this kind of a ticket -- short, simple, to the point, and with a fix. :)

fixed in r7079.

comment:3 Changed 13 years ago by KyleK

  • Resolution fixed deleted
  • Status changed from closed to reopened

I've thought a bit over this and think there might still be a problem now, because for others zlib might actually be located at /usr/local. In that case the script will fail.

I've tried doing a rewrite (using check-ssl.m4 as template) but my m4 programming skills are nonexistant, unfortunately. Maybe someone else can have a look?

comment:4 Changed 13 years ago by charles

  • Resolution set to fixed
  • Status changed from reopened to closed

KyleK: I just swapped out the old m4 file with a different one used in other projects.

Note: See TracTickets for help on using tickets.