Opened 12 years ago

Closed 12 years ago

#1444 closed Bug (invalid)

Multi-column lists seize the mouse cursor when trying to set smaller width than min

Reported by: marcabru Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 1.34+
Severity: Minor Keywords:
Cc:

Description

Some columns are not resizeable (eg, the encyrption-sign at the first column of the peer list). Some are resizeable, and there is a minimum width (all the others, eg. IP address). WHen I try to resize these columns and I drag the column-separator left to the minimum width, it seizes the mouse cursor in a very strange way:

1) If I release the left button anywhere in the screen but not at the list header, the mouse cursor stays as it was: <-->, so I can't even switch to other application with the mouse.

2) If I release the left button on the list header, setting the column height to a correct (>=min) size, the mouse cursor is released again.

To sum up:

The column resizing is not fool-proof: it seizes the cursor as long as you do not set a correct column-width.

Expected behaviour: When you're adjusting the column widths, and you set it to <min sizes, and release the mouse button, it should reset to the original width, and just release the mouse cursor, as if nothing had happened. Like a scrollbar, when you drag it beyond it's range.

I think it's a minor bug, but very strange because it does not happen with other GTK multi-column lists (e.g. Nautilus), should be easy to fix if triaged.

The bug is related to this one: http://trac.transmissionbt.com/ticket/1439

I use GNU/Linux i686 2.6.24, Ubuntu Hardy (8.04.1), xorg 7.3, GTK 2.12.9, Gnome 2.22.3, Transmission 1.34+ (7073) installed from latest SVN to date.

Change History (1)

comment:1 Changed 12 years ago by marcabru

  • Resolution set to invalid
  • Status changed from new to closed

Sorry. I start over with a separate ticket for the peer list.

Note: See TracTickets for help on using tickets.