Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#1461 closed Bug (worksforme)

iPhone specific browser opening new windows/tabs

Reported by: irae Owned by: Gimp
Priority: Normal Milestone: None Set
Component: Web Client Version:
Severity: Normal Keywords: iphone, webapp, home screen, patch
Cc:

Description

I'm using Transmission on Mac, version 1.40 (7084).

Added as Home Screen icon on iPhone.

When I "filter" by "All", "Donwloading", "Seeding" or "Paused" it is opening another window on safari. This is an new tab on my safari witch has the address bar and everything.

Maybe being and "apple-mobile-web-app-capable" implies that all operations are ajax-driven, so to not reload the page or request other address. But I don't really know, just guessing....

Also, it seams that the feature by Apple is itself broken. Look at this post for some info: http://nrbd.tumblr.com/post/55066018/apple-mobile-web-app-capable-is-really-broken

Attachments (1)

remove_apple_iphone_speciffic_browser.patch (657 bytes) - added by irae 12 years ago.
Patch to solve the bug, by removing the feature until Apple updates iPhone resolving the bug.

Download all attachments as: .zip

Change History (12)

comment:1 Changed 12 years ago by livings124

  • Milestone changed from 1.41 to None Set

comment:2 Changed 12 years ago by charles

irae: when you set a milestone, you're essentially ordering the development team to do this, and to do it on your timetable. Please do not set milestones unless you're attaching a patch or you're going to start giving us paychecks.

comment:3 Changed 12 years ago by irae

I'm sorry for that.

It won't happen again.

I'll download the source and try to make a patch. But in the forums it was requested as "one line only" feature, so to remove I thought it was an one line removal. Nevertheless I reckon this was wrong of me.

Thanks for the advise.

comment:4 Changed 12 years ago by charles

I don't have an iPhone and have no idea how easy or hard this feature is... I'm just stating the milestone policy. ;)

comment:5 Changed 12 years ago by KyleK

I'm not sure if this is iPhone-related. It can be replicated in Firefox if you bookmark the web interface and tell Firefox to open the bookmark in the sidebar. It will show up just fine, you can pause torrents within the sidebar, but when you add or delete a torrent, Firefox opens a new tab/window.

comment:6 Changed 12 years ago by irae

But IMHO removing the <meta> tag (that works only for iPhone BTW) it's a good idea anyway. Or at least until the feature is addressed by Apple in upcoming iPhone updates.

For those witch don't have access to an iPhone to understand, if the user adds Transmission to home screen the only way to avoid the buggy behavior is to have the <meta> tag removed.

I made the removal and tested it. Attached patch.

Please, let me know if the patch is OK. I never submitted a patch before. If this is OK I plan to contribute more with the Web and iPhone interfaces. If the patch is in wrong format, please, can you point me to some good reading in this area?

Changed 12 years ago by irae

Patch to solve the bug, by removing the feature until Apple updates iPhone resolving the bug.

comment:7 Changed 12 years ago by irae

  • Keywords patch added

comment:8 Changed 12 years ago by livings124

Does this bug still occur with the iPhone OS 2.2.

comment:9 Changed 12 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed
  • Version 1.40 deleted

This post makes is seem like Apple fixed this bug. I'm going to close because 1. A forum user says it's fixed. 2. Even if it's not, this is more than likely an Apple bug.

comment:10 Changed 12 years ago by irae

Just adding a note.

I was under the impression that livings124 was asking a question, just forgot the question mark.

But I've tested it. The bug is really gone in iPhone 2.2 firmware making the feature useful again.

If it was not, nevertheless, the bug and patch could remain open, it was a (tested and patched) one-line solution to a great problem.

comment:11 Changed 12 years ago by livings124

Heh, I forgot to add the actual post in the forms. But no worries, it's confirmed fixed by Apple.

Note: See TracTickets for help on using tickets.